Instructables

i was repairing a home amplifier when it "unrepaired" itself. help?

i found a samsung mm-c430 home amplifier the other day, and decided to take a stab at fixing it.
i replaced a few burnt out parts and tried it out. nothing.
then, while using my multimeter to check things, i noticed the main transformer wasnt putting out any voltages. this lead to more probing around a mosfet when suddenly the VFD lit up and the device appreared operational. my multimeter had shorted out two contacts and that led to the system starting up the way it should, rather than just turning on the LEDs.
i turned off the device and turned it back on, and just the LEDs lit up. then i went back with my multimeter to the same spot and t started again!
so i went and soldered two wires and a load (resistor) and went back to try again. the resistor burned, and the device did not power up properly. i tried again with my multimeter and nothing.
i removed the wires and tried again, and still nothing. now im really confused with whats going on here. can anyone help?
attached a photo. it was taken before any repairs were done, but the two points are labeled.

the chip is a pwm controller, and the pin labeled is VCC

Picture of i was repairing a home amplifier when it
First off, follow Rick's advice. Do as he advises and get back to us.

Now for my synopsis.
You have a problem in the PWM circuit that somehow feeds the MOSFET. When you touched VCC to the center pin of the MOSFET, you applied enough voltage to turn it (the MOSFET) on and it stayed on because there was a voltage in the feedback loop to that same pin. When you removed the power from the overall circuit, the feedback voltage went away and the initial problem resurfaced. Adding the resistor to the gate of the MOSFET allowed too much voltage to be present and it sounds like you fried the MOSFET.

If you want to know how that happened, think about what the impedance/resistance of your DMM is rated (not what the range is selected/set to) - probably presents around 10 MegOhm. That would drop quite a bit of voltage and really limit the current going through. Too small of a load resistor would let too high of a voltage and current through, plus when you start to get the feedback, it can add to the voltage. If the gate of the MOSFET saw a voltage higher than it was rated, it was most likely compromised.

Also, what's all that brown gook all over that area? Looks like something went all 'splodey in there.

Qa
zack247 (author)  Quercus austrina2 years ago
scratch that-- there is NO voltage present at the transformer.
Input (120 volts AC)

or

output (something smaller I expect?

If the output then if you can disconnect the transformer and check the resistance of the output coil (Secondary)

Come back with information.
zack247 (author)  rickharris2 years ago
at the input of the transformer.
theres 5 pins on the AC side, im not sure why, but with any combination i dont get any voltages.
i'll get a picture of the transformer when i can, hopefully i can power it up without the control circuitry using a simplified circuit that delivers the 120 AC volts when the amp is powered up.

I removed the transformer, theres no damage to it, but the amp powers up like it did when i got it, only starting up the 5v circuitry via the smaller transformer.
A picture might be a good starting point for investigating the transformer. I await!
zack247 (author)  rickharris2 years ago
ok, here is the transformer.
the side with 5 pins and the writing is the AC side.
100_1158.JPG100_1159.JPG
Ok I think the most likely configuration is as in the diagram below subject to anyone else's opinions.

You can check across the individual windings to see what you get with your meter.

What you get might give you more information It looks like the Power supply may be a switch mode PSU as the transformer is very small.

These operate by switching the AC very quickly on and off. because the driver transistor (MOSFET in your case) is either on or off very little power is dissipated in the semiconductor and the high frequency allows for a much smaller transformer.

IF the transformer is open cct OR shorted you may (JUST be lucky) find that this is close to the start of the winding and you can take off a few turns and resolder the wire and get it working.

Otherwise you will need to start thinking of an alternative PSU or recycling.
zack247 (author)  rickharris2 years ago
if it is a switching supply (which i would assume it is, based on it being used in such a device), would i be able to take a functioning switching supply and swap the transformers?
If i can then i can save a lot of time seeing as how i have many switching PSUs laying around.

and if i cant do that, would i be able to determine the voltages that the secondary coils put out?
The transformer design is based on the voltages needed and the frequency of the switching. If you can find a similar transformer then it "might" be worth a try - but keep fingers crossed.

I assume you have checked and have open circuit or short circuit windings?

As for the voltages without some guide either on the PCB or components I can't think of a way to find out.

Capacitors will have a max voltages but this may well be a lot over the supply.

transistors have a design working voltage you can look up from their specification.

For 10$ you can buy the service manual here

http://www.electronicsrepair.net/rec18mm.shtml

that may help you/us.

I guess Samsung will be the best source for a spare part if your sure the transformer is s dead.
zack247 (author)  rickharris2 years ago
the voltages are marked on the board, but the problem is that its not in volts, but "vxx" and "-vxx" (xx representing different letters) the ground pins are easily identifiable, but not the others.

the capacitors are rated well above what they need to be. 50v.

I'll keep my fingers crossed and look around at the PSUs ive got, maybe i can get this to work.
if i could just find out those voltages i could just put a new power supply in, unfortunately its not so easy :/
I indicated in my post above where you can buy the service manual from this should show a circuit diagram with the voltages on.

$10 isn't a lot.
zack247 (author)  rickharris2 years ago
i know $10 isnt a lot, but thats also $10 i dont have at the moment.
OK then your going to have to go down the lets take the transformer to bits route then.

Test with meter first though to make sure it's bust.

PS making or buying a PSU will be a lot more than $10
zack247 (author)  rickharris2 years ago
i know the transformer works. the system did power up before, the problem lies in the circuitry that controls the power going to the transformer.

i was looking at some of my PSUs today and the switching supplies from desktop computers have transformers with the same pinout on the AC side.
( | | | | | )
im thinking i'll try swapping the transformers when i get the time to do so.
and i can get PSUs for nothing here. i dont mind getting used ones.
The cct will be something like this
zack247 (author)  rickharris2 years ago
i havent got the time- or parts, to be able to make that circuit, but there has got to be some way to determine the voltages required by the mainboard.
i know the capacitors arent going to be helpful, and i know that 5v is already being constantly supplied by a smaller transformer.
some other voltages, like 3.3v, are listed elsewhere on the board, perhaps i should see if they trace back to the transformer?
should i also check the operating voltages of the ICs to see if they can give me a hint?

i remember being told in my electronics class that transformers are wound in a ratio, so, knowing the number of windings on the primary coil, i should be able to determine the voltages based off the number of windings off the secondary coil, right? or does that not apply to switching supply transformers?
I posted the cct not so you could make one but so you can get some idea of what you have on the board. IF the transformer is OK then the problem is with the other electronic components or the actual PCB itself.
zack247 (author)  rickharris2 years ago
sorry, i misunderstood.

i did identify two of the pins;
the VFD- and VFD+ pins are for powering the VFD display.
its 10v or under.
that just leaves 4 more pins to figure out.
Isn't it worth $10 to get the service manual?
zack247 (author)  rickharris2 years ago
Possibly, but thats $10 i dont have for spending on service manuals that may or may not exist. There should be more than one place where i can find one, and the only one i can find is the link you sent.
Itll just take a little bit of probing to find the last 4 pins.
zack247 (author)  Quercus austrina2 years ago
after more probing, this is what ive found.
the pin 2 on the mosfet is the "drain" pin. im assuming here that the powering up was a side effect of my probing and wouldnt call that a success.
pin 1, the gate, is not receiving any voltage. in theory, if i apply voltage, the mosfet should let the power through and allow the system to start up, right?

the mains power is getting to the transformer, but of the 5 pins, only 2 of them. im making a safe assumption that the other 3 are controlled by the mosfet.
there is no output on the transformer. there is, but each output is less than 1v.

i cant find any dry joints, they all appear to be ok.

im not sure what the brown stuff was, i cleaned it off using a small brush. it doesnt appear to have harmed any components.

any help is appreciated, and if you need more info let me know.
rickharris2 years ago
The upper point appears to have the symbol for a capacitor on the board but no component (this isn't unusual. The picture isn't detailed enough to see anything else.

HOWEVER some essential fault finding principles can be applied.

1. Take care, a mains powered system bites and can/will kill you if your unlucky.

2. Check the mains is getting to the transformer primary (REMEMBER THAT CAUTION IN POINT !)

3. Check the secondary out put (this is still AC if NO output disconnect the secondary wires and check again. If the secondary voltage is there something on the PCB is pulling it down. If no secondary voltage you have a faulty transformer.

4 The secondary voltage is rectified by probably 4 diodes and a largish capacitor & a couple of resistors. Check for this DC voltage at the ends of the diode bridge and across the capacitor.

5. If this is not there switch off and check the diodes on resistance. this may be confusing but they should each be similar.

6. Your symptoms suggest a break in the board or a poorly soldered component (dry joint) You may be able to bend the board by pressing, see the break with a magnifying glass or find the dry (dull and grey) joint by poking round with an INSULATED probe.

Come back if you get more information from all this.

zack247 (author)  rickharris2 years ago
i think after sleeping on it i have a bit of a better idea for whats going on here.
i know the transformer works-- the entire amplifier was working properly before something went wrong. something is up with that mosfet. (attached to the heatsink) im guessing when my multimeter went from the vcc of the pwm chip to that spot (which leads to the center pin on the mosfet), it activated the mosfet and the circuit turned on. im pretty sure when i soldered the wires i did something wrong so i have a feeling i burned out the mosfet.

what i'll do after i get back from school today is check around the mosfet and see if theres voltage present on that center pin. if not, then theres something else not working right and i'll have to follow the traces until i find that component.
zack247 (author)  zack2472 years ago
i just realized a mistake in my first part. the other pad (the upper one) goes directly to the center pin of the mosfet.