is there a fix to my ambilight 2812B endless malfuncion?

I am using ~170 LEDs (2812b) with a 10A 5V PS. the power is connected to two parts of the strips due to voltage drop that results in a yellowish white color, close to the end of the strip.

I also added a 1000uF 6.3V Cap on the PS and a 470ohm Resistor on the Din starting point. GND connected to the Arduino and using Ambibox software.

after a few weeks of usage and especially when turned on, the LEDs flicker or stuck on a certain color up until led (x). few minutes later it overcome whatever problem it had and works regularly. Alas, on white color (guess when it consume the max current) it start to flick again mostly on this led(x) again.

of course, I replaced led(x) and led(x-1), enjoy a few weeks of the Ambilight project working perfectly and then another led(y) want my attention and again and again....

should I replace the whole strip? am I using too much current? is it a known issue?or there is a galaxy where these leds replacement slaving don't occur.

thanks in advance

steveastrouk8 months ago

I would connect 170 LEDS in more than two places to the PSU !!

I see numbers like 0.25 W/ LED. 170 LEDs = 42W, which is pretty close to the 50 your supply can deliver anyway. You're probably pulling too much current in the ends - like nearly 5A, assuming you feed from both ends.

Get some seriously heavy feeder wires - something like 0.25mm^2 or something like that.

1+
People like to think because LED's are considered low current devices that they get away with minor flaws.
The fact is that LED strips should be considered the same way like you want to drive a serious heating element instead.
And noone would really use thin headphone wires or such to power them...
The longer the connecting cables are the thicker they need to be - check the recomendations for car audio setups and their power supply...
Back in the day when we installed the first LED information boards they literally used copper bars to power the hundreds of LEDs - just to make sure the voltage and amps are within the right range at every single point of the system.
Just for comparison:
One of the signs we used had only around 600 LED's.
Still the copper bars used were around 2 x 0.5cm and as long as the LED array.....

One of the problems is these damned things are sold in long integral strips, and the uninitiated assume that means you can feed them at their ends and be OK. My LED Christmas tree project had five feeders !

https://www.instructables.com/id/Pi-ece-on-Earth/

iceng8 months ago

I agree with Steve... Get a second power supply !

When the current gets near its limit, the voltage droops and individual LEDrivers do not really turn full on, they (the individual drivers) start to partially turn on which is a high power for any transistor (not fully on or fully off) guaranteed overheat to fail !!