loading

l293d ,problem wth the output current?

Hey people , i have build a line follower robot using -(arduino,motor controller(l293d), IR modules and sensors)


WELL NOW I HAVE GOT A NEW METALLIC CHASSIS(its kinda heavy).Earlier we use a cardboard box and it worked just fine .

But now the motor driver is not able to give enough current to drive the cart.But when i connected it without the motor driver its able to drive the cart forward.

So my conclusion is that the IC (l293d) is the cause of my problems,so i want to know how i might be able to fix it OR if  i have to use another ic like (SN754410 H-Bridge)



sort by: active | newest | oldest

@iceng, I an sorry if I sounded mean .I am not used to these kind of technical talks.

But any way thanks for you help

I did pick up the cart and the wheels would start to turn instantaneously ,.The solution that I found on the web is to use two l293d in parallel so it would give double the current than it used to give .otherwise I will have to use a more efficient motor controller ,say from Texas instru!ents

As I said.

No problem :) and you are not mean. I was not polite.

But back to what may be the real problem and why the continued need to learn if the wheel with controller will turn.

When there is no load on the motor being controlled, as occurs when chassis is lifted so the wheel could turn almost free and thereby low low current for the controller.

iceng iceng3 years ago

IF it does not turn the problem is not the controller but simply the battery voltage is too low for your situation.

IF on the other hand it does turn then perhaps your parallel 293's will work.

rickharris3 years ago

Your only looking at 600Ma per motor for the L293D this isn't going to drive a motor that is very big or under a lot of load.

You have 3 options.

Get a motor driver that offers more current.

Use relays

Use the L293 to drive 4 transistors that can supply the current your motor needs : to find out how much you need you should measure the motor current whilst the motor in loaded drive it directly from the battery.

cthaliyath (author) 3 years ago

I does turn when I pick it up,I told you right when I connect the batteries directly to the motor it is able to propel with a decent enough speed(but with the motor driver ,its not moving )

See if it turns using the l293 when picked up ( this unloads the motor ).

Why would do you think, I would ask to repeat an expeirment you alraedy did ! ! ! ! !

Now you asked for help.

It would help if you understood that I am trying to determine if the system is under powered to supply this controller.

And BTW mpilchfamily is talking to you about the same sort of information.

I guess your not used to talking with technical people trying to help you :-/

This is common. The controller isn't 100% efficient so you loose some power in the form of heat. In your case just enough to make it not work. What you may need to do is give the system more power if the controller can handle it. If not then get a better controller that can handle the power.

iceng3 years ago

The L293 is loosing just enough power to be unable to turn the motor load under weight.

See is it turns when you pick the toy up ?