loading

leaf blower runs starts and stops fine butt once turned off it wont go on for a hour

i think it is a model defect because my friend has one with the same problem butt i still want to fix it

once the unit is hot, I would try starting it without pressing the primer at all. A primer button is primarily used for a cold start situation. But if it is a purge button that brings gas to the carburator (look in the carb and press the button, if you don't see any gas flow or squirt into the carb throat then it is a purge button) I would press it the 8 times. Make sure that your miture ratio is at 50 parts gas to 1 part oil. (5 liters gas, 100ml oil) Also make sure your gasoline is fresh. Gasoline now adays only has a maximum 3 month shelf life before it starts to deteriorate. Make sure your air filter is clean otherwise it may be limiting air flow and riching up the mixture to much. You could also check your kill switch. once if run it , shut it off and can't get it started again, remove the spark plug, put it back into the sparkplug boot, let the sparkplug touch something metal like the cylinder of muffler and pull the unit over and check if the sparkplug sparks. make sure not to hold onto the sparkplug. Power equipment like that can create upto 18 kV. Try those things and check out those things, let me know how you make out.
ema328 years ago
This may sound obvious, but does it have a primer, & are you using it each time? Try checking the spark plug is clean of soot, a wire brush should clean any off, also check your air filter is clean. (Assuming its a petrol model) Using the wrong fuel mix or leaving the choke on is also a common problem, if your fuel is too rich it'll choke up your pipes! Hope that helps.
mclovin7596 (author)  ema328 years ago
its all clean new spark plug and the primer says press 8 times butt it wont start so i press it 2 times