loading

solar circuit not working properly? any ideas?

I am building a solar powered charger for when I go on holiday, I know there are already some instructables on this but and can't seem to find anything to do with my problem.

I use the solar panels to charge Ni-MH batteries  and when I test them in a simple circuit i.e. solar panels connected straight to the batteries, they charge but in my circuit below the battery connections on the casing heat up and the casing smokes. Obviously this is a problem but I don't know what is causing it.

My schematic is below.

Stu

Picture of solar circuit not working properly? any ideas?
sort by: active | newest | oldest
Which terminal do YOU think is the positive of the battery and the cells ? There's an LED without a series resistor, I can't see how you ever get power to the 7805, since you short the input to ground on it. Describe what you THINK its supposed to do ? There are three pins shown next to the Ni-Mh, but there is nothing shown about how you intend to connect them
stuart576 (author)  steveastrouk6 years ago
I on my schematic the long cell lines are positive and the short ones are negative, I read that to charge rechargeable batteries you connect the positive terminal of the battery to the positive terminal of the charger (opposite to powering something like an LED) and negative leads together. Is this right? I think I need a diode to stop shorting the regulator if I remember rightly I put one in the circuit, just missed it off the diagram. Those three pins next to the Ni-MH batteries is a three pole switch but I didn't know the correct symbol for it.
Yes, +ve is the long cell line, but around the regulator you have a "battery" which is the wrong way round, and the diode on top of the NiMh is the wrong way round.

Where is the "output" of the circuit ?

Try this symbol for your switch

Redraw it, as Fram suggests, and lets take another look at it.

stuart576 (author)  steveastrouk6 years ago
Here is the schematic redone with framistan's tips:
IMG_20100803_154941.jpg
Weeeellll.
  • What's the battery voltage ?
  • The battery isn't connected to your ground line at all.
  • Your sign convention for +ve and -ve seems to have broken down again.
  • The LED to the phone will melt, unless the phone draws less than 20mA
  • The phone pri
  • What are the zener diodes on the right side for ?
  • Mounting the regulator behind a diode means that the load will only see 4.2V, not 5
Drawing tip. Where there IS a join in a cross over, NEVER draw it as a cross ! Put two, T joints next to each other. By modern convention, there is now NO joint at the crossover.
stuart576 (author)  steveastrouk6 years ago
Ok, redone the circuit again, thanks for the help by the way, it's invaluable. - The battery voltage is 1.25v each so 5v. - My signs were wrong I was trying to charge the phone from the wrong end of the battery. - LED now relocated to after the phone. - The phone pri - I don't know what you mean. - That little circuit is a battery charging indicator, I'm using two different voltaged zener diodes one for when the battery is charging and is low, and a slightly higher one for when it is fully charged as the voltages will be different. - Diode now removed, not needed as there is a switch that will be open when batteries are charging the phone, so no ground, no reverse voltage, right? I think I've changed the 'crossover' bit you were on about (in between the two switches?) All this help is appreciated. Thanks
IMG_20100803_182950.jpg
That's a lot better ! ;-)

The crossover is now much easier to see and understand isn't it ?

Now, all that's needed is your charging light is in the wrong place. Put the LED to the positive terminal, and tie the negatove terminal to ground.

The two "charging LEDs" will never light, since both ends are always grounded !
framistan6 years ago
Your schematic is somewhat twisted oddly. Here is how to fix this problem. First, re-draw your schematic but this time follow some of these GUIDELINES. 1. place voltage SOURCES at the left of page. Loads towards the RIGHT side of the page. 2. Try to keep POSITIVE wires (lines) towards the TOP of the page. 3. Anything connected to battery NEGATIVE just draw a GROUND symbol which indicates chassis ground or battery negative. 4. Do not draw ANY crossover lines if at all possible. (you did pretty good on that one). because crossover lines add to the confusion/complexity of the drawing. If you follow those BASIC guidelines you will make a schematic that will be EASY to read and easier to build without errors. One error on your schematic is the switch connected at the input of your 7805 voltage regulator. The switch should probably be connected to BATTERY PLUS... not Solar-Cell negative... if i am reading your solarcell polarity correctly?? The LED near the solar cells needs a series resistor. I have partially redrawn your schematic for you. I think after you re-do your schematic, you will be able to build your circuit and then it will work. Using YOUR schematic, i find it difficult to see what ONE thing may be wrong because so many SMALL errors exist on the schematic.
solar_schematic.JPG
stuart576 (author)  framistan6 years ago
Thanks for the tips, just doing a new schematic now.
That's not what he's drawn either. Look at the original regulator connections.
lemonie6 years ago

"the casing heat up and the casing smokes. Obviously this is a problem"
Yes it is. You really need a proper charging-device for this.

L

sherlock.JPG