loading

the heater fan in my 1993 geo prizm quit working?

at first the fan would go on and off now and then if i hit a speed bump or a mud puddle. if it wouldnt come back on i could open my hood and slam it back down and the fan would start. now my fan quit working all together. i have tried to look for loose wires under the glove box and to check fuzes. i checked the fuzes under the hood and when i was looking under the glovebox (as well as possible) i noticed 2 more fuzes. do u think this is a loose wire or fuze problem or a burnt heater.  whats the best way to get to the heater fan. and where is the fuze located

sort by: active | newest | oldest
Re-design7 years ago
If it's a multispeed fan there is probably a resistor somewhere in the circuit that is installed in the air flow duct somewhere.  It's put there for cooling.  I had one that was intermitant and had to find it to replace it.
Sounds like a loose wire, probably on the way to the heater circuit, though the heater and fans are buried deep in the dash in most cars, which means it might be really hard to track down, if the fuses are intact then loose wire or possibly motor mount are likely causes since it started with speedbumps and slamming the hood.

If it is the motor mount it's just a case of the fan sticking against something, it could be the motor itself though they seem to live beyond most other pieces of the car so I'd be surprised.
NachoMahma7 years ago

To find the fuse you need to look in the engine compartment somewhere close to the battery on the wheel well, and also there is one up under the dash on the drivers side.  From what you describe though it sounds as if you got a wire that is grounding somewhere and that will be a big pain to track down.  You best bet is start at the battery and follow the wires, all the wires, till they enter the driver compartment.  Check for loose connections or worn or frayed wires.  Good luck.

lemonie7 years ago
Heaters can be difficult, they may require taking a lot of dashboard off. Fuses are protective devices, if they need replacing they're telling you there's something else wrong. The fan may be "sticky", or have loose connections somewhere. You'd have to get it out and look at it I think.

L