why does my junkbot go around in circles? PLease help! :( ?

Hey Hi there! I'm a newbie in the field of robotics and electronics, I just finished making my first junkbot.(its the one with 2 9v d.c motors on the side connected to a switch and a battery pack.) It works kinda ok but it gets pulled towards its left and then rotates in that axis. I'm stumped @ this stage now, can any one suggest pointers? Thnx in advance ! :)

Picture of why does my junkbot go around in circles? PLease help! :( ?
sort by: active | newest | oldest
smokedkraken (author) 5 years ago
Thnx guys! , I tried lengthening the spindle on the left (by adding a slightly wider wheel) , sure the rotation stopped but the traction became all messed up, nw the wheels just spin around.... As of now, i'm working on the traction. Thank you once again guys! :)
iceng5 years ago
Cheep ( low co$t ) motors are vastly different in rotary speed.
Put a 1 ohm resistor in series with the outside (faster) motor.
 
A
Burf5 years ago
The obvious answer is more power is being transferred to the ground by the wheel on the outside of the arc in which the vehicle turns than that on the inside.
This could be due to the motor on the weak side delivering less power, the drive train on the weak side doesn't rotate as freely as the outer wheels, the tires are getting less traction or a combination of those things.
Troubleshoot those items to determine where the problem(s) are.
iceng Burf5 years ago
+1
frollard5 years ago
because the motors aren't straight; one is off to an angle.