3D Printer XYZ Axis Problem

So, I finished building my 3D printer. I installed the firmware, etc. Whenever I try to print in repetier the X and Y axis move really fast while the Z axis doesn't go up nor down. I have tried so much to fix but I just can't find a solution. Also, I have the MK9 Extruder and for some reason the extruder doesn't feed the filament, it just stays there. In case you ask, I have not be able to print anything.

There is a video of the process, and sorry for the mess.

sort by: active | newest | oldest
1-10 of 15Next »
Yonatan241 year ago

The video didn't embed.

I barely know anything about 3D Printers, but I'd guess that there's something wrong with the code, or the motor (You've probably checked this a million times, but just in case...)

JoeM286 (author)  Yonatan241 year ago

I forgot to say that I am new to this, I followed instruction on how to set each things. I could post the Marlin info here so if anyone can figure out what's wrong.

It is next to impossible to diagnose the problem without access to the printer.
1. The firmware must be cofigured correctly to the hardware.
2. The stepping and endstops must be defined correctly.
3. The motor drivers need to be set to the correct amperage for the motor connected.
4. The entire system must be calibrated.
Usually after all this you try to print something and do the finetuning.

JoeM286 (author)  Downunder35m1 year ago

1. I posted some of the firmware configuration so any of you can take a look and see if something is wrong.

2. I have tried to switch the endstop to different location, etc. Nothing seems to happen so I guess the configuration might be wrong.

3. I saw something concerning this but I don't know if they are adjusted the right way.

4. I been trying to figure out how to calibrate the system, but I keep getting errors or sometimes some of the lines in Marlin don't even exist for me.

All this is fine but how would I know the actual hardware in your machine and how it is set up?
Check the Reprap forum for Tiffids calibriation guide and go from there.

JoeM286 (author)  Downunder35m1 year ago

You can see the video if it gives you any clue if something is wrong.

The only thing the video tells me is that at least one motor is running with far too much current - that beeping noise is from your motor...
For the rest it seems you don't understand the problem:
What is your endstop logic and location - how is it set in the firmware?
What temp sensor is used and how is it set in the firmware?
What is the axis configuration, hardware and firmware?
All this and more needs to match up before you address problems like the stepping, pid control or speeds....
And there is no way to firgure that out by pics or a video - you have to match this by checking your hardware and the corresponding firmware settings.

JoeM286 (author)  Downunder35m1 year ago

You can check the firmware in one of the comments below that I posted. For the temperature I ran the PID Autotune to get a code for the thermistors. Like I said, I have followed multiple instruction on how to set my 3D printer, but I can't get it to work.

Any specific help forums for your brand of printer?

Did you actually have any model to print and did it get sliced properly to generate gcode before printing?

You should go through the bed leveling procedures before attempting to print.

Your extruder nozzle may be jammed or the feeder is not adjusted properly to grip the filament. Do you see the extruder motor turn? The filament may not have been pushed all the way into the hot end. You can manually push through some filiament while the hot end is heated up to see some filament oozing out.

If you have the correct firmware loaded on your printer, the software must be configured with the right profile for the printer settings.

Also, the hot end heats up, then the heated bed has to come to temperature before the actual print. Maybe the erratic xy movement is the head trying to find home position before the print, your endstop switches may not be hooked up or working correctly.

Yup, a lot of things to figure out when owning a 3D printer. Good luck.

JoeM286 (author)  caitlinsdad1 year ago

I have not be able to print anything as the filament does not go through the hotend. I have tested two different extruder nozzle and both are acting the same, so there might be something else wrong. I tried to push the filament but it doesn't go through. I posted some of the firmware configuration in case there is soemthing wrong.

1-10 of 15Next »