Add Image Notes feature broken

I am attempting to add image notes to a new instructable, but the "Add Image Notes" tool endlessly shows a spinning wheel and reports, "saving your note..."  I've tired on several different photos in several different instructables using the following browsers:
Google Chrome 10.0.648.82 beta
Safari Version 5.0.3 (6533.19.4)

Under OS X.  

Anyone else experiencing this annoying bug?

sort by: active | newest | oldest
1-10 of 22Next »
Kiteman6 years ago
There is a known but inconsistent issue with image notes which the code-monkeys have some ideas about, but it looks like fixing it is going to take a rewrite of the entire autosave javascript.

Apparently.
I've made this sticky. Maybe other users who read this post might notice.
jimk30386 years ago
Still seems broken.

However, I've made a discovery (I sure hope this helps get the problem solved).

When adding a note to a picture, keep the text really short and NO error will be generated.

Adding a note with a long message generates an error every time.

So, the bug must have something to do with the length of the text in the message!

Bottom line, keep'em short for now.
ilpug jimk30386 years ago
i have tried Mac Safari, and Google Chrome and Internet Explorer running on a windows XP computer. I tried keeping notes as short as one word, or one letter, and it still doesent work.
jeff-o6 years ago
I was having this issue last night. It would seem that it doesn't like commas ( , ) and slashes ( / ) in the text field. I don't know if there are other special characters causing troubles, those are the only two I noticed (and would really have liked to use...) I don't think length was an issue, though I only typed in two dozen words at most.

I am running Mac OS X. In Firefox, I get an error message right away, similar to what jimk3038 posted below. In Safari, I just get an endless spinning beachball.

The images stick just fine if I leave out those special characters.
jimk3038 jeff-o6 years ago
Yep, I just reproduced your findings. I took a large block of text and removed all the punctuation except for periods. So, all the text was upper / lower case letters, spaces, and a few periods. That seemed to be OK.

BUT, add just one comma and it would blow up! Funny how hard it is to write without any commas at all.

Hey instructables staff, what's the ETA on fixing this bug? This has been a known bug for almost a month. I'm in a holding pattern until this is fixed.
jeff-o jimk30386 years ago
At least you can copy the text from the error message, so you don't have to type everything all over again...
jimk3038 jeff-o6 years ago
Oh, I've made it a habit to hit control-a then control-c before hitting the save button. If there is an error I can just start a new tag and then paste the text right back in. Then begins the hunt for the offending character.
jimk30386 years ago
Still broken!

Maybe each hour it stays broken we should all post another comment here. Then, after a few hundred posts maybe someone inside instructibles will get the hint.

Squeaky wheel gets the grease.
CharredPC6 years ago
Tried multiple browsers, no success at all. Adding image notes results in error popups or a spinning wheel with no actual saving. This bug is physically stopping me from posting up new Instructables. Do you want fresh content on your website, or is that not important? I'd consider this a top priority problem.
1-10 of 22Next »