Instructables

Brake lights

So i have a '95 chevy suburban, and it has a few issues. at the moment, the biggest issue is my brake lights. Basically, when the vehicle is in accessory and i depress the brake peddle, my brake lights come on, YAY! but when i have the vehicle running and i depress the brake peddle, the 15 A fuse blows and the lights go out. now i have a schematic diagram for the whole vehicle (in parts), but im still trying having a hard time finding where my problem is. im sure there is a short somewhere but it is just all really confusing to me. thanks much in advance.

note: night time lights work as well as all turn signals. 

Hello Friends,

The lighting system of a motor vehicle consists of lighting and signalling devices mounted or integrated to the front, sides, rear, and in some cases the top of the motor vehicle. The purpose of this system is to provide illumination for the driver to operate the vehicle safely after dark, to increase the conspicuity of the vehicle, and to display information about the vehicle's presence, position, size, direction of travel, and driver's intentions regarding direction and speed of travel.
Many types of lamps are used for turn signal, brake lamps, side and clearance marker lamps, and interior lamps. Standardized type numbers are used by manufacturers to identify bulbs with the same specifications. Bases may be bayonet-type with one or two contacts, plastic or glass wedge, or other types such as wire-loop or metal caps used on tubular lamps. Screw-base lamps are never used in automobile applications due to their loosening under vibration. Signal lamps may have clear bulbs, or may be coated red or amber to provide extra contrast in brake-lamp and turn-signal applications.

Thanks and Regards,
Umang Kumar
That a really odd fault, Have a look at anywhere the wiring has been modified like the trailer plug, new radio, alarms etc. Also check the back of the ignition switch for modification or wear. Do the reverse light work?
DanJames (author)  liquidhandwash1 year ago
oh lord...trailer plug: modified. Radio: new(ish). Alarm: installed but i uninstalled it because it was causing issues elsewhere. ill look at the ignition switch tomorrow. havent checked the reverse lights yet! ill get on that. thanks!
One more thing to check, do you have kids? they like to put coins in the cigarette lighter, (stop laughing) Ive seen this a few times.
Cookies in the cd player of my computer.
Trailer lights are most likely from what I've found...
DanJames (author)  killerjackalope1 year ago
yeah...ive looked into it already too and i thought i had restored the original wiring design but i guess not if that is in fact what is causing the problem. if not then i still need to look elsewhere. maybe i grounded the system at the wrong spot?
move the parking brake one click and try it again.
DanJames (author)  Josehf Murchison1 year ago
ive had the parking brake on and off...is that what you mean?
Yes but not untill the brakes are applied, if you did, did it make a diference when you tried the breaks or did it still blow the fuse?
The break peddle goes to ground when applied and so does the parking break in some models, others it can be the reverse.