Instructables

Bug report

I am using Firefox 10.0.1 on  Compaq AMD 4450e 2300 mHz, Windows 7 version 6.0.6002 Service Pack 2 Build 6002. When open my pending topic and hit the EDIT button I get a pop up screen with teh following message:

There's been a problem updating your Instructable
parsererror
SyntaxError: JSON.parse: bad control character in string literal

 
The tab locks up and a little "UPLOADING" icon flashes at the bottom. It stays forever , or until you close the tab. I can't edit the topic and I am not sure why.

I started writing in word and did a cut and paste to put the first paragraph into the first step. No picture, no graphics,. Just a few sentences of text.

Your help would be rgeatly appreciated.

vectorges (author) 2 years ago
When I look at the ible in Chrome there was a slash in the title. When I look at it Firefox the slash is replaced by three weird characters. I edited it in Chrome, saved, and re-published. Now I can edit it in Firefox.
vectorges (author) 2 years ago
Philip42 gets the prize. I had been using Firefox. I followed his advice and tried Chrome. I was able to edit it, add new content, save it and publish it. Now I just have to get the 4 abortive versions deleted.

Thanx for the hint. I have no idea why hte browser would make a diffeance, but it did.
philip422 years ago
Same problem, with the inability to delete the garbaged ones.

The strange thing is I've always been using Word (Word 97 to be precise - it does what I need it to do and I've never felt the need to upgrade) and out of 20+ instructables this is the first one where I've had these problems.
The site undergoes updates all the time, so a method that was once fine, may just be incompatible now, or it could be a bug. Unfortunately, if you've started an instructable that's now "stuck", you'll have to email staff so that they can remove it.

It's been my experience that Word can create some problems, not always, but it can, and a lot of it depends on specific characters and formatting. So to avoid that, I try and only use a "plain text editor" and format the text in the Instructables editor.

I hope that helps.
I'm 90% certain that it was caused by having a special character in the title of the instructable (e.g. "computer's").

I normally use Firefox but somebody suggested using another browser to try to edit/delete the garbaged instructables and that worked.

To play it safe for the instructables I've edited today I first paste the text into notepad (which is a plain text editor) and then copy them from notepad and past them into the instructables engine and that's been working.
Notepad should help in avoiding this issue. I suggested it to the author of this bug report but they continued to have problems, so I'm not sure why. As a plain text editor it doesn't paste all the formatting characters as does Word.

It's interesting that you got another browser to help you in editing/deleting the messed up instructables. I'll have to remember that in case it can work for someone else, so thanks for sharing that! ;)
canucksgirl2 years ago
The problem with copying and pasting from word, is that its not just pasting the visible characters, its pasting "non printing characters" which is the formatting code for your text.

If you are unable to edit your instructable now, chances are you'll have to delete it and start over.

In the future, use a "plain text editor" like "Notepad" (free with windows) or "TextEdit" (for Mac), because they won't include any non printing characters. You can also start with word (if you're more comfortable), just paste the text from word into a plain text editor first, then re-copy the text and paste it into your instructable. It'll save you a lot of hassle in the future.
vectorges (author)  canucksgirl2 years ago
That was an excellent response. I would expect a cut-and-paste on the screen to be smart enough to work asa wysiwyg. Any way, it didn't work. I used notepad, and it did the same thing. Maybe we need an Instructable to read a notepad text file and retype it as an instructable input ;-)
I don't want to annoy you here, but are you sure you weren't using "wordpad"? Notepad has always been a plain text editor and doesn't support rich text formatting; but wordpad does... they both come with windows.
vectorges (author)  canucksgirl2 years ago
It is notepad. Also, is there a way to delete the four versions that are currently pending? The two options appear to be EDIT and PUBLISH. I know that EDIT loops. Publish doesn't do any good since it isn't finished. I guess I will just retype it. Aah, efficiency.
Well there's a couple ways you can deal with this now. Yes, you can delete them, but if you have a version that's almost completed, you might be able to save it. Open the ible in 'edit' mode, then in the editor options (where you pick text formatting etc) you'll see an option for "source", if you click on that, it'll give you the "source" code of the text. If you know coding at all, you should be able to delete the non printing characters that are causing your problems. You want to delete everything but the wysiwyg text. Then to exit "source" mode, just click on the "source" button again (as its the only option available). Finally, use the options within the editor to format your text.

To delete unpublished instructables, open them one at a time in "edit" mode, then look to the right of the tabs (edit, publish, share) for the word "More" and a down arrow. Click on that and then select "delete". You'll be prompted with an "are you sure" message, so press the appropriate button.

If you need more help, just let me know. :)
vectorges (author)  canucksgirl2 years ago
Excellent answer. EXCEPT, I can't edit the ible. That is the entire problem. SO, without using the EDIT button, i there a way to delete them?
You're right. I forgot that that was the whole problem...

You will have to contact instructables and ask that they delete them. Be clear as to which ones (maybe provide a screen shot of the unpublished list?) so there is no error made. There isn't a way for you to delete them outside of edit mode, but the programmers can take care of this, (and hopefully address why this occurred in the first place!) You can also say that you've reported this as a bug, however, there is no way for you to correct this issue.

email: service AT instructables DOT com
Pro

Get More Out of Instructables

Already have an Account?

close

PDF Downloads
As a Pro member, you will gain access to download any Instructable in the PDF format. You also have the ability to customize your PDF download.

Upgrade to Pro today!