Instructables

Can't paste text using Google Chrome

Well I can't copy and paste text, like the title says. I am aware that people using Firefox and Internet Explorer do not have this problem, but really I would prefer to use Google Chrome. It was fine before the new editor came in, everything was really simple before then. When the new editor first came out, I overcame the problem by pasting my text as a link, and then simply removing the link, leaving normal text. But now (as someone else pointed out) I can't even do this, because the link thing is broken! Why can't we just go back to the old editor : ( 

noahw4 years ago
We'll do our best to support Chrome in making changes to the editor going forward.  For the time being though it doesn't look like very likely that we'll be rolling things back to the old editor.
DJ Radio noahw4 years ago
It would be nice if we had an option to switch back and forth.
Do you recall this discussion from last year, DJ?  The "editor" is merely the front-end part of the system which is visible to the user.  The underlying ASCII which goes into the I'bles database is itself completely different! 

The old system had special purpose markup characters, which were converted by the server at output time into HTML.  The new system (CKEditor) actually produces HTML up front, which gets written as it to the database. 

Providing something on the front end to "switch back and forth" would mean designing and developing a JavaScript engine which could, on the fly, reprocess whatever the user has typed to become either the old markup or new HTML.  And that reprocessing would have to be able to deal with incomplete markup (since you might switch interfaces after you had opened a bold tag, but before closing it).

What is more, the new HTML markup does not include all of the "features" (weird tricks) available with the old special-purpose system, so a back-and-forth mapping is not even possible in principle.
Oh I forgot about that.
JohnJY4 years ago
 I have had the same problem, and it's still not fixed. 
Lowney (author) 4 years ago
BUMP
 bump
Lowney (author)  matthewvenn4 years ago
 lol
Chicken22094 years ago
 Is it the ctrl + v method or is it the method where you go through the menu and click paste, because I can remember having problems with the shortcuts before in chrome, but usually the menus still worked
Lowney (author)  Chicken22094 years ago
Nothing works (ctrl+v or right click then paste)
 Did you try clicking ( i think the wrench menu) and clicking paste there?
Lowney (author)  Chicken22094 years ago
I did but it did not work :(
 then I don't know, sorry
It doesn't work in chrome for me either, but I primarily use Firefox. You can run a live version on Firefox from PortableApps if you don't wish to install it.
Lowney (author)  plane phanatic4 years ago
 Nah tbh I prefer Google Chrome. Besides the link thing works now but it would still be nice to not bother with the hassle 
Lowney (author) 4 years ago
Pah