Instructables

Can't post replies due to captcha

Seems captcha is blocking posting comments.  Here are my symptoms:

OS: Ubuntu Linux 12.10
Browsers: Firefox 21.0 & Google Chrome 27.0.1453.110
Instructables Account: Logged in with Facebook
Rich text: On or Off same result
Error: On submit I receive a message in a modal window saying, "Please type the two words as seen on image"

There is no captcha from which I can read the two words displayed, only the text, "This helps us reduce spam." displayed below the comment box.

[edit]: change title and tags to be more descriptive.

mikeasaurus9 months ago
Please see this forum topic for all issues relating to Captcha not working.

This thread is now locked.
Redo It Yourself9 months ago
"unmatching captcha values"
Cleared cache, etc. and problem still exists.
Redo It Yourself9 months ago
I am having the same problem, but I am trying to publish my instruction project. There are no captcha boxes, yet each time I try to publish it comes up "unmatched".
I'm having the exact same issue. I have tried in chrome, firefox, ie, safari and dolphin (I'm thorough), and I don't see the captcha box anywhere. I even tried clearing the cache and disabling things like ad-block. It is extremely annoying since this is the last day to submit to the Halloween costume contest.
nalipaz (author) 1 year ago
Okay, I can post a comment, but not a reply. I tried posting a comment and then subsequently posting a reply and/or refreshing the page and then posting a reply after passing the captcha for the comment. Nothing works. Impossible to post a reply due to captcha not rendering below the reply box. I even tried filling in the captcha at the comment box and then filling out a reply and hitting the reply on the reply box. Never works.

As for all the other options, they do not make a difference. This issue was duplicated in two browsers as well.
mikeasaurus nalipaz1 year ago
You should only need to solve the Captcha once. As suggested, try leaving a comment (not a reply) and solve the Captcha. After, navigate to another page on our site, or refresh your page and check to see that your comment was successfully left. After, you should be good to leave a reply.

Please see my earlier comment on other browser issues that can prevent comments from appearing.
dhhd mikeasaurus1 year ago
hello
joecooning dhhd9 months ago
hi
apamplona9 months ago
I tried on Windows 8 with the most current Firefox and with MSIE 10 and have run into this issue. I've been able to post in the past (last attempt being months ago).
uiftikhar9 months ago
I am not able to post as well. posting this comment for test.
bjarmstr9 months ago
I have Windows Vista with Firefox 25 and IE 9. I also have a ipad2. I can't get my instructable to publish and I can't write a bug report because I am not seeing the captcha field.
nalipaz (author) 1 year ago
Mike, if you fully read my prior comment you would know that I did leave a comment and then refresh the page as well as other tests. Even now when going to a page I am still getting the captcha. I have to redo the captcha on every comment.

I do not attribute this issue to my browser settings since I have tried in two different browsers on two different machines. Please read the original issue that tells you which browsers I am using.

Without trying to sound "holier-than-thou" (I am just trying to help here), I should mention that I do backend and frontend website programming for a living and I can assure you I know how to bypass/clear my cache and test browser issues. For me however, your issue on this site is not displaying any errors in the console and only the symptoms are apparent or I would've sent you the errors the browser was throwing up. My guess would be something to do with cross-domain scripting that silently errors.

I think I have given you enough information to duplicate this issue on your end. If you do have additional questions on how to reproduce I will be glad to help, otherwise I assume it isn't enough of a concern for your team and it just won't be fixed or tested. I will just have to work around the issue by avoiding making replies to other peoples' comments and only making comments on your site.

I am sure others who have had this issue just didn't care enough to report it. Best of luck.
nalipaz (author)  nalipaz1 year ago
BTW, this page does not require any captcha for me. The following does require me to input the captcha every time:
http://www.instructables.com/id/How-to-Fry-the-Perfect-Donut/
mikeasaurus1 year ago
Please make sure you are not using any script-blocking add-ons (like Ad-Block or GreaseMonkey), and that you are using the latest browser, with cookies enabled. Then refrsh the page. Try first leaving a comment (not a reply) and solving the Captcha (you will only have to do this once).
Also, make sure your browser text is at the default (ctrl+0) so that the Captcha window shows up correctly.

Did any of those options help?