Instructables

Embedded video not working/playing

I have noticed for a week or 2 (maybe more) that when someone embeds a video (Youtube seems to be the main culprit) the only thing I see is the black video area with the Youtube play button in the middle. Clicking on the play button does nothing except push you to the next line on the page. Yes, the cursor says that it is active/available to do an action.

I use Win 7 Home 64bit and IE8 (don't laugh, I don't laugh at others for their choices).

An example of an 'ible that does this is R-KAid Redelux. Scroll about 1/2 way down for the video.

Even looking at the source code, I get the same problem if I copy and paste the video link in a new window. Here's a snippet of the code:

<br />
Here&acute;s a video of how the machine actually works:<br />
<div class="media_embed">
<iframe allowfullscreen="" frameborder="0" height="315" src="http://www.youtube.com/embed/WghZEalbddw" width="560"></iframe></div>
<br />

And here's the direct link: http://www.youtube.com/embed/WghZEalbddw which does the same thing, ie nothing.

Is it Instructables or is it Youtube? Seems to be the YT code and if so, it should be stated which style embed code to use that works. ie, check "Use Old Embed Code" on Youtube's site. In this case, it would be:

<object width="560" height="315"><param name="movie" value="http://www.youtube.com/v/WghZEalbddw?hl=en_US&amp;version=3"></param><param name="allowFullScreen" value="true"></param><param name="allowscriptaccess" value="always"></param><embed src="http://www.youtube.com/v/WghZEalbddw?hl=en_US&amp;version=3" type="application/x-shockwave-flash" width="560" height="315" allowscriptaccess="always" allowfullscreen="true"></embed></object>

Lastly, is it my choice of browser? Possibly.

Thanks for looking this matter over,
Qa

Quercus austrina (author) 1 year ago
I believe you are right mikeasaurus. I have viewed the page I linked on an older computer (XP sp2 and IE8) and it works fine. The difference between these 2 versions of IE8 is that the one on the Win7 machine has a Protected Mode under Security and it doesn't like when the video is embedded on Instructables. I guess I will update to a newer browser even though I hate the thought of losing the way I have become accustomed.

Thanks for looking into my query.

Qa
i tried it and it worked for me I use firefox.
I cannot recreate this issue and can watch the video fine in the example link you provided.

If you are having trouble embedding the code then I think it may be a small error on your end that might be preventing it from displaying correctly (such as a mistyped character).

If you are having trouble viewing someone else's video on our site then you might want to make sure you have the latest browser / have no add-ons installed that might be preventing the page from loading or displaying correctly / might just need to refresh the page.
Quercus austrina (author) 1 year ago
Interestingly enough, I've pasted both codes into a basic web page (strictly HTML) and they work just fine. The only difference is that the first "compact" embed version shows the "share" icon in the top title bar while the "old code" does not. Clicking the play button on both produces the desired result - playing of the video.

Could it be something in your CSS or other code that is preventing the videos from playing, not Youtube's code(s)? A temporary work around would be to encourage authors to add a separate, direct link, such as: Video link or http://youtu.be/WghZEalbddw.

Qa
quietkey1 year ago
yikes i cant get the video to play either but It's not you it's me ,I too am windows 7 64 bit,but I did notice recently that my web cam{fixed} in the start menu has disappeared, when I checked in system devices(where i can roll back or update) it says it's working properly, and in device manager ,there is no yellow "!" before it.I'm pretty illiterate as ar as computers go so if anyone should run across this and knows what I should do please tell me.Ive never had any problems viewing instructables before and have subscribed for4+ years.hmmmm .thankz :P