Instructables

Error message

I got a big PROBLEM, can you help me?
I am unable to upload an Instructable after the fourth or fifth Photo.
While saving, an error message is coming on a black page and the page is getting hanged.
The message is.......( There's been a problem updating your Instructable parsererror, Syntax error JSON. parse: bad control character in string literal)

Picture of Error message
Dipankar (author) 2 years ago
When I "add" the photo to the Instructable, while auto save. All Photos below 300KB. in jpg. format.
Can you please PM me the url to the unpublished project you are having trouble with?
When you're trying to add the photo, are you doing so right after you have "copied and pasted" text into the Instructable? The reason I ask that, is during the auto saving process when you are adding an image, the site is also taking your text content and attempting to save it (if you didn't click the save button before adding images), so if there is an "offending character" in your text, it may appear that the image itself is causing the problem, when in fact the text in your Instructable is.

Can you clarify if you have saved your Instructable prior to adding the photo's?
Dipankar (author)  canucksgirl2 years ago
I had not saved before adding a new Photo because of auto save.
First I Copy paste the text and then I upload the Photo, and that is when the page hangs and the Error message appears. This happens after I have gone to Step 4 or 5, before that it is OK.
Quite frequently, when copying and pasting text from another program (like MS Word), there are "non-printing characters" that get included when you paste into the editor for your Instructable. I believe that's where the problem is. There is generally very few issues that occur with adding photos.

The first thing that you should do is ensure that you use a "plain text editor" like TextEdit (for a Mac) or Notepad (for Windows). Just ensure that the text within the editor is set to plain text before you copy the text to paste it into the Instructables editor. Then you should click on the save button. If that all goes okay, then you should be able to add your photos without anymore problems.
Dipankar (author)  canucksgirl2 years ago
I did all you said but the same message is coming when saving text. The test is in Notepad. What should I do?
What that tells me is there are "non-printing" characters (basically code) that's still being copied over and pasted into the Instructables editor and therefore its creating the error message.

So, make sure that the notepad file is saved as a .txt file and then copy and paste into the ibles editor using the button that's for "paste as plain text". Its the icon with a yellow folder and a tiny blue notepad on it... and its located 20 icons from the left.
You'll notice that when you click on that icon a secondary window opens and allows you to paste your content in there.

Once you've done that click the "OK" button and save your Instructable. At this point, you should have no further errors.

(Just make sure you follow the same process on each step).

If you're still having problems with it, let me know.... (I'll be online for awhile).
Dipankar (author)  canucksgirl2 years ago
Same Problem.
Even using the button that's for "paste as plain text" did not work.
Got stuck in the 4th. step, without uploading any Photo's.
I don't know what more to do. Any ideas...........
I know this can be frustrating... If you managed to get to the 4th step, then the button is working to stop most of the offending code. In the 4th step however, do you have any unusual characters (i.e brackets etc) that may be causing an issue? <> Brackets like the ones shown, are used to contain code, so they are usually not recommended for use within your Ible text.

If checking your text isn't going to solve the problem, then I would suggest emailing staff and link them to this page, so that they can offer up some more suggestions.
Dipankar (author)  canucksgirl2 years ago
No unusual characters or brackets.
How do I link this page to the emailing staff?
Thanks for trying to help me.
Just copy this page's URL from your web browser and paste it into an email to them at the service@ address, but include some more info, saying that you've tried to complete an Instructable and you continue to get errors, and you've been helped on this page. 

http://www.instructables.com/community/Error-message/
Dipankar (author)  canucksgirl2 years ago
OK let me try with notepad, Thanks, I will let you know the result, thanks again.
mikeasaurus2 years ago
I've passed this along to our bugs team. What web browser(IE, Firefox., etc.) and computer operating system are you using (Windows/Mac version)
canucksgirl2 years ago
OS info, browser info???

It could be a conflicting character that you used in the Instructable text, or in image notes. Its really hard to say without more information, so I would suggest that you go over your text and see if you haven't used an unusual character, and if so, remove it and try re-saving.

BTW, if you're still hung up on that page, the only thing you can do is close the browser and then re-open your Instructable (provided you saved it at some point).
Dipankar (author)  canucksgirl2 years ago
It is not getting hung on text, but only on Photo. Please help.
Start by clearing your browsers cache and reload the site. Then make sure you save your Instructable before you add any photos. If you still have the problem, let us know if the error occurs when you are trying to "upload" the photo OR if the problem happens when you "add" the photo to the Instructable. Include the file type info (png, jpg etc), and the size of the photo file.
rimar20002 years ago
1) Click F5.

2) Update your navigator.