loading

FAQ: How Do I Format Text?



Now a full-fledged iBle! This topic is no longer being updated. Go here for latest version. 2009-01-22




IblesFormatting

This shows some of the formatting codes available on Instructables.
Please do not use the comments for testing. I suggest using your Orangeboard. TIA.

1. Font Styles

2. Headings

3. Paragraphs

4. Preformatted Text

5. Links

5.1. Escaping Links

6. Macros

7. Miscellaneous

7.1 Horizontal Rule (HR)

7.2 Bullets

8. Underlining

9. "Special" Characters


sort by: active | newest | oldest
1-10 of 102Next »
kelseymh8 years ago
Very interesting issue with the "Heading" markup (equals signs).

In a Forum topic (as above), or in an I'ble, the Headings correspond to differently sized text (inconsistent with typical browsers, but still different). In individual comments, the use of Heading markup has been disabled (they're simply ignored).

However, if you use Heading markup and preview comment the text is rendered in the appropriate size, as shown above! It's only suppressed when you actually post.
NachoMahma (author)  kelseymh8 years ago
. My guess is that's caused by a quick-fix for ppl abusing headings in comments - they forgot to fix the preview. . This formatting business just keeps getting curiouser and curiouser ;)
kelseymh8 years ago
Hi, Nacho et al. FYI, the new server code no longer accepts Zach's curious workaround for square brackets. It now puts up a "red box" warning "link is invalid." The numeric entites are now the only way to put literal brackets into text.
NachoMahma (author)  kelseymh8 years ago
.
gumwrapper8 years ago
I tried to add apostrophes to my slide show labels, but I couldn't get them to format properly. I tried the ampersand, pound, ascii number, and semicolon method but it just put in the work "apos" in there. I tried to just put three (3) curly brackets around the text - that did nothing. Any suggestions on how I can put apostrophes in my slide show captions?
It might work here'
or here
nut's
For simple apostrophes (next to the [return] key on U.S. keyboards), you just type them as normal text: Don't 'cha think we're goin' ahead? Maybe you mean something more complicated? If you could post a link to your slideshow (if it's unpublished, you can get the URL from your profile listing), maybe you could point out specifically what you're having trouble with.
It's just something in the caption field of my slideshow. I don't know if it applied to all slideshows or all captions. The problem occurs in my slideshow:
slideshow
I also have a problem where I will save changes and publish them, but it takes some time before I can see the results (even in preview mode).
NachoMahma (author)  gumwrapper8 years ago
. Sounds like a problem with the slideshow gizmo. . I'd try using & apos; and & amp; (remove the spaces). Might work; might not.
Hi, Nacho. In fact, on the "Director's Chair" slide, he used a straight apostrophe and it got rendered as "'" :-/ I've recommended that 'gumwrapper' create a bug report.
1-10 of 102Next »