Instructables

Glitches -- who can fix them?

Two problems:  

One, my latest instructable,  http://www.instructables.com/id/Hanging-Candle-Holder  shows zero views, yet it has comments and a 4 star rating.  Who can get the views counter going?

Two, sign-in.   When I log on, I always check the "keep me signed in" box, but it never keeps me signed in.  Every time I leave the site and come back I have to log on again.  Does anybody have the wrench to fix that?

For your first issue: We did some updates to the site yesterday and managed to cause some errors here and there. This is one that we know about, and we're actively working to get it fixed.

To your second issues: That shouldn't happen. What web browser (include version) are you using? Have you tried clearing out all your cookies/cache just in case there's something old in there getting things mixed up?
Thinkenstein (author)  StumpChunkman1 year ago
I think I found the answer to my sign in problem. I had signed in on a friend's computer and aparently checked the "Keep me signed in" box. Although I wasn't able to keep signed in on my home computer after that, I was still signed in when I got back to my friend's computer. I have just signed out and temporarily signed in again, which I expect to again enable my home computer for permanent sign in.

With my email server, if I check "Keep me signed in" on another computer and then do the same on my home computer, I think it overwrites the old order and keeps me signed in on my home computer. Maybe there could be some way to work that overwrite ability into the instructables server? Otherwise, if you are traveling and keep signed in on a distant computer you never revisit, you might never be able to fix the sign in problem at home.
That second problem occurs to me always, since many months ago.

I previously used the desktop PC, but almost a year ago I decided to use the notebook.

I found that if I enter Instructables on PC, no need to login, but always in the notebook I must login.

I guess that is because Instructables identifies the association  user-IP, which in my opinion should not happen.
Hey Rimar,

I'm not sure why that's going on. I do a lot of bug testing, so I have four different computer/operating systems that I use instructables on (and at least three different browsers loaded on each of the system). I've never had trouble with being auto-logged out unless there were some bugs going on on the site (which they're aren't in that respect right now). My netbook and desktop both stay logged in fine when the computer or the browser are restarted.

Could you see what your security settings are on the machine you're getting logged out of? Make sure they match the one that stays logged in.

You can also trying clearing all of your cache/cookies in case there's an old cookie on your computer that's causing all the rukus.

Sorry I couldn't be of more help.
StumpChunkman, sorry, I understand you. I was programmer, analyst-programmer and analyst since 1972 until the end of 2009 when I retired, and I know that these things happen.

Fortunately this problem is not important, I've solved by the simple expedient of not turning off the notebook for weeks, just close it, and so the next time when I open it, only takes a few seconds to wake up and return to the state I leave it.

Thanks for your concern!
Do you run identical test suites on all hardware/software combinations ? What are you using for auto-testing out of interest ?
Depends on what people need. I actually have a few more computers then I wrote about. Each of the following systems is run on its own machine. I have the latest two releases of Ubuntu, Windows 7 64bit, Windows 7 32bit, Windows XP, Latest 2 releases of Mac OSX, a third Mac OSX on a non-intel machine, an iPad2, and an Android device.

Each of those (minus the mobile devices) have Firefox and Chrome (or Chromium) (Mostly the current releases, but I'll download an older one for testing if someone says they're using it). The Windows Machines run one of the latest two releases of IE and the Macs run Safari. Those are what I do my day-to-day working/testing on. When someone says they have a specific problem with a browser, I'll go find and download it. Two of the browsers I can remember doing testing to find problems on were Maxthon 3 and Opera, but I don't use them when I don't have to. I use the iPad and Android browsers, and have download alternate browsers on each of those devices to check on specific functionality elements, but keep to the default on most occasions.

When there's issues with not seeing things on the web page, I'll figure out what add-on's people have on their browsers, install those and see if I can't replicate the problem.

Some notable exceptions: I sometimes run different Linux Disto's off of a Flash drive to access either the KDE interface or non-Ubuntu systems. I've also had to use my PS3 and Nintendo DS to assist two different people with issues they were having, which was quite interesting and made me never want to use either of those again for web browsing.

I'm fairly certain that covers the gambit of my machinery/things I use to test on. I have access to other OSs, Devices and Browsers but I've never needed to access them for testing purposes.

As to auto-testing, that's something that our coding team does, I can ask them about it and see what they say. I know that a lot of testing of new releases is done by everyone at work.

Hopefully that covers it, I think I went into way more detail then I needed to.
Go tell Frenzy the keywords editor no longer shows up. So that makes it moot to update or delete keywords that are somehow encapsulated with double quotes to keep keywords together. My sew easy arduino shield has malformed keywords. It was not fixed since his non-commentable site update was posted announcing the fix. You know, opening up those site updates for comments would allow you to track better which bugs may be associated with that release instead of getting random bug reports. And by the way, my scarf for the cure was published before an ibles system crash back in Feb and I think it has it's viewcount counter messed up since then. Quality is job 1! Look at where that got the auto industry.
Consider your message forwarded. The view count is something that's messed up for everyone. The dev are trying to figure out what's going on with that right now and how to fix it. The keyword problem is another one that I'm fairly certain that's on our queue of things that we're also working on. I promise, there's quite a list that we found immediately after release of things that need to get fixed. Really sorry about that.
Which is partly why I asked about testing. Someone ain't telling you what they've broken properly, so you can't test it.
I've actually grown apathetic to the bugs, like the inbox counter that is stuck at 1 with no unread messages which I've learned to ignore for a year. But hey, as long as you and Mikey are fielding questions, it makes it all good.
hahaha. We do try. But when something weird like that happens to just you...or you and 15 out of a million people...it's hard to figure out why you're special. You should just be happy knowing that you're special. ^_^
.
hahahaha...Nice!
That was to illustrate the bug that videos don't fit in your window. You cannot clear off the ads that appear on the bottom.
I did notice that...and clicked over to youtube to watch it.

...perhaps I'm becoming immune to the bugs as well.
Though, to be fair, in Chrome I had the problem. Firefox seems to work fine.

Screenshot at 2012-04-18 13:23:06.png
* note to self, add opening titles to videos - Watch in Firefox instead of Chrome until something there breaks *
Hah! No worries, I've passed the issue on. Hopefully we'll have time soon to fix it.
On a ame but different matter I was looking to set up an acc. for my son who uses my PC too. But I don't see where to go to sign out of my account inorder to create a new one. Anytime I open or link into instructables I'm logged on automactically which is handy of course but now that I want to create a new account I can't get out??? It like hotel california!!!!
hahahahaha...You want to get logged out, other people want to stay logged in. See, this is the problem we face. Everyone wants something different!

But not to worry. Top right corner of the page should be a logout link. Find the "You" link at the top, and it's to the right of that.

If all else fails, you can always just delete your instructables cookie (but there's really no reason you should have to do that).
Yeah so I've tried this before (just did give the details before because I had forgotten exactly how it all went). I've tried clicking on log out but it only takes me to the home page but I'm still logged in.

Whats this about the instructable cookies could you explain that? thanks
Sure, what browser are you using and on what operating system?

If you let me know that, I can let you know how to find it.
TheHebe1 year ago
Hey Bill!
http://www.e-zeeinternet.com/ Bookmark the page so you can get a new code for each upload you produce on youtube. Insert at bottom or top of your instructions. Small hassle til you form a habit.
caitlinsdad2 years ago
Sorry friend, I can only offer the instructables suggestion box.  I do have an ible though that seems stalled on viewcounts also, and that is one of my serious ones.


DSC03041.JPG
Pro

Get More Out of Instructables

Already have an Account?

close

PDF Downloads
As a Pro member, you will gain access to download any Instructable in the PDF format. You also have the ability to customize your PDF download.

Upgrade to Pro today!