loading

Help me fix ma zune!

I've got to fix this damn zune, there's no warrenty on it and all in all it's a piece of crap. The guy doesn't care that much if it can't be fixed. I've got shit webcam reference pictures. You'll see that the battery has the terminals connected to a small IC board with 3 solder pads on it, and a voltage regulator of some sort on the bottomside of it. The ribbon cable has 3 little metal spades that solder to those pads on the battery. There's voltage coming out of the pads (I don't have a voltmeter, just a tongue but that works just as good). When I've got the ribbon cable soldered to the battery and I touch the end of it to my tongue I can feel current, so why is it that only once in a while I get power to the zune? Like if I wiggle the cable around sometimes I can get a low battery symbol to come up and then it shuts off. I don't know why it's still showing a low batt symbol because I charged it and it feels like there's a good charge in there so what's the problem? I wanna get this fixed so I can play around with it, no I've never had the pleasure of a zune :p. Thanks guys for anything you can help me with. I was thinking maybe the IC came loose from soldering/desoldering the cable a few times, but it still appears to be stuck on the board pretty good. Well look at the pictures and decide for yourself. It's starting to look like I'll be buying a new battery, which apparently the ipod 30/60 gig batteries are the same size/amperage and can be used in the zune and at a low price of $14, I can probably get a battery that'll last longer than the factory one eh?

Picture of Help me fix ma zune!
backside.jpg
battandribboncable.jpg
solderpads.jpg
battery3.jpg
cable.jpg
sort by: active | newest | oldest
1-10 of 12Next »
jtobako9 years ago
There's a good chance the ribbon is broken in the middle or at the other end. You need to check continuity to the circuit board. That or the lithium battery charging circuit needs to be re-set-it may think that the battery is bad and refuse to use it.
Punkguyta (author)  jtobako9 years ago
I noticed that if I shorted the pos and neg that the current would start coming out of the cable again and then shut off, so how would I reset it?
Check the manual for replacing a dead battery : ) It may be as simple as disconnecting the battery completely for a while, or you may have to discharge a capacitor or deal with the bios.
Punkguyta (author)  jtobako9 years ago
Well I don't have the manual for one, and it's like the ipod, wasn't designed to be replaced except in the tech shop.
Time to hit other forums and search to see if someone-possibly a tech from MS-will have an answer.
or, in the best case scenario, there will be a small button :-)
Goodhart9 years ago
depending on the solder joint (I have seen visibly solid joints that where in reality, loose, or cracked, even if only a hairline crack) A broken with inside the cable is just as possible. You really need to acquire a voltmeter lol
Punkguyta (author)  Goodhart9 years ago
I had a voltmeter and I was using it to fix some guy's car stereo and he still has it but he's just F****** weird and I don't talk to him anymore so I guess I gotta go buy a new one. And I re soldered it soooo many times trying to get it to work, it's so hard to get a solid connection on such a small scale isn't it?
Yeah, and I have the added curse of fading eyesight. I have trouble with "regular" resistors and the color bands, and the printing on "throughhole IC's, caps, and especially diodes, much less surface mount stuff.
Punkguyta (author)  Goodhart9 years ago
I'm thinking I'll just buy him a new battery, apparently the 60/80 gig ipod colour's have the same kind of battery as the zune, and for $14.99 at ifixit.com I can get one with a higher amperage than the factory one = longer battery than the lousy 12 hours it was supposed to be able to do.
1-10 of 12Next »