loading

How do i fix this zafira problem

Help zafira w reg keeps losing power almost feels like it's braking?i have a w reg 2000 zafira elegance 1.8 petrol and i have got a problem with it losing power big time at low speeds and quite serverly when cruise at 60-70 mph it almost feels like the brakes have been applied then all of a sudden it picks up and flies off. i've had the engine managment light come on so had it put on the computer at main dealer they found code p0100 and p0505 which they charged £250 to tell me and convert the air flow sensor (allegedly as i don't see any sign of work done) .then thay said i need a new throttle body and iac valve new mass airflow sensor and pipes new crankshaft sensor new camshaft sensor plus a new ecu but can't quarantee that will fix it so what do i do pay the £3500 for them to try that or plead for help on the internet for ideas on possible solutions so here i am please could someone help

LinuxH4x0r9 years ago
Its not worth it to put that much money into an old car. I'd just move on
Though it could well be one of the expensive problems the management system could be at fault.. . Also check the throttle body and cable, have someone rev the engine moving the accelerator up and down a good bit, look for cable slacking or the throttle body responding incorrectly, thankfully they don't use electric throttles, fly by wire are always cheap to fix../
mpramse9 years ago
my car had a very similar problem and all it was, was the crank shaft positioning sensor. It was $34 US so it should be cheap for you too, but I dont know that car. But hope that helps.