Instructables

Introduction is garbled

Normal0falsefalsefalseEN-USX-NONEX-NONE/* Style Definitions */table.MsoNormalTable{mso-style-
 
The above is what appears on the main page of Instructables (not in my actual instructable!) as the introduction to my instructable for making a leather kippah. I tried removing my image and uploading it again, removing the intro text and adding it again. Nothing solved it.  It may be related to the images? I uploaded them using the new, Flash-based uploader.

My URL is http://www.instructables.com/id/NO-SEW-LEATHER-KIPPAH-Yamulkah/

 

BobbiWired4 years ago
I also have the same issue. Is there no work around rather than completely rewriting 3 instructables from scratch??? *whine*
I just looked at your 3 Instructables and they look fine to me.  Can you show me with a screen capture or link what formatting has been affected?

Thanks,
Noah
Hi Noah -
Hope you can see the screen-shot - It only shows that way in thumbnail view or looking at just the table of contents. This particular one was just featured - it is on the homepage at the bottom of the "featured" on the left. This is the text that shows  -   Normal0falsefalsefalseEN-USX-NONEX-NONE/* Style Definitions */table.MsoNormalTable{mso-style- If you go view the instruct' in "view all steps on one page its fine - it's like this just in thumbnail and table of contents view ;P

I tried typing it directly instead of copy/paste from a word doc, but it didn't help anything. All 3 look this way.....
many thanks for your help :))
Bobbi
FireShot capture #007 - 'Instructables - Make, How To, and DIY' - www_instructables_com.png
gmoon4 years ago
This is a known bug.

Those look like M$ formatting codes, rather than gibberish. I believe this happens when you copy-and-paste from a word-processing program like MS Word...

Notice how the text displays correctly within each step, but not in the table of contents. The new editor is happy to accept RTF formatting codes, and the actual pages are smart enough to interpret them correctly. However, the scripting that produces the table of contents dynamically is based on the old editor, and needs updating...
Britex_Fabrics (author)  gmoon4 years ago
So do you know what I do to get around this? I tried using the cut & paste box for Word and for text, but got the same result with each.

Oddly, I did not have this issue with my first Instructable (http://www.instructables.com/id/Easy-Flapper-Headband/) even though I cut and pasted from Word for this one too.
 
I could be wrong, of course. But I've had similar problems. I think they've been tweeking and changing the system a lot (converting to the new editor.)

BTW, formatting codes showed up in the TOC even with the old editor--if for instance you bolded the first few characters, the codes (not the formatting) showed up in the contents.

That's still the case with the new editor, even with non-copy-n-pasted text. So avoid any formatting at the beginning of any step.

You might try rewriting the first paragraph by hand (within instructables), then deleting the old version... or saving the Word doc as text only, loading and copy-paste from "Notepad" instead...
Britex_Fabrics (author)  gmoon4 years ago
Thanks for your kind suggestions.

I tried saving the Word doc as text only, loading and copy-paste from "Notepad", but that did not solve it. I skipped the bit of bolded formatting. I rewrote step 7 by hand (within instructables). None of these solutions worked! Grrrrr......

Once I open the Instructable, this happens as I scroll over each step image.
 
Right--the scripting grabs the text when you mouse-over, and displays it without any filtering.

I guess unless all the formatting is deleted first, the artifact will remain. Maybe first select all the text (Control-A), then delete? Before repasteing or typing...

At this point the only sure way is to insert a new step, then paste from Notepad or other text editor...but that means rebuilding the ible completely :P

But I know you're not the first with this issue.
Britex_Fabrics (author)  gmoon4 years ago
I redid the whole thing. Sigh......hopefully, my next one will not be so problematic! You have been very helpful.
Pro

Get More Out of Instructables

Already have an Account?

close

PDF Downloads
As a Pro member, you will gain access to download any Instructable in the PDF format. You also have the ability to customize your PDF download.

Upgrade to Pro today!