LM386-amp power problem

I have built an LM386-amp from the schematic in Nicholas Collins "Handmade electronic music". It works fine with a 9v-battery but when I use a Roland guitar pedal power supply (several outputs) my chip is ruined. Does someone know how I can get this to work with a DC-adapter?

Picture of LM386-amp power problem
IMG_1819.JPG
verence7 days ago

With the wrong polarity a IC can be fried in a fraction of a second - even without getting hot or letting the magical smoke out. And it will not heal itself when the polarity is corrected. Try and get a new LM386.

Some chips may survive a wrong polarity for a short time, some for a longer time, some not at all.

daaaaavid (author) 25 days ago

The chip is fried. Actually I had the wrong polarity, but the chip still stopped working when I changed it (didn't get warm though). Strange. Realised I should check with a multimeter, but as a newbie I couldn't get a signal. hm.

On the label of the power supply it shows the supplied DV is only rectified and with basic filtering.
Usually for the old stuff based on transformers it means a bridge rectifier and a single electrolytic capacitor.
It also means the output voltage can be quite a bit higher than the stated 9V until a suitable load is connected.
With a badly filtered DC you can get distortions, humming noises and other problems but I doubt enough to fry your chip.
As Iceng suggested you should double check the polarity of your connection to the power supply - it is always a good option to includea diode to prevent frying electronics if connected with the wrong polarity.
I would also check the output of the power supply itself and if correct add a little LC filter.

gmoon1 month ago

The chip is fried, or it doesn't sound good?

The LM386 should be OK with up to 12VDC. Are you sure the Roland unit is DC? If so, is the polarity correct?

Have you tried the LM386 setup alone? (nothing else daisy-chained?)