loading

Laptop Battery.....

My Laptop battery  for some reason is being all fluky. I plugged the laptop in, so it can not run off the battery, but it still did. So I plugged it in somewhere else, and the laptop was/is  still running off the battery. I turned it off now, but I don't know what's going on. Can someone help me?



                    Also, the green light an the power cable is on, but the computer isn't registering it (The power I mean). I can't even turn the darn thing back on.

sort by: active | newest | oldest
You can check the power supply is functioning with a volt-meter by shoving one probe in the centre hole of the connector and touching the other on the outside. It should register about 20V, the actual value should be printed on the bottom.

If the supply itself is working, you should test for voltage between various combinations of pins on the battery connector, to see if it is trying to output power to charge the battery.

If the supply is working, but no voltage it seen at the battery connector, you will have to open it up and check for broken connections or a loose connector.

One more thing: Test the output of the supply after it has been plugged into the laptop, as no voltage means there is a short in the laptop somewhere.

Hope this helps.
kenizl86 (author)  The Skinnerz6 years ago
Well, I tested the wire that goes into the adapter box, and it was putting in something. Then I tested the output cable, and nothing was being put out. I tested it and different settings with my digital multimeter, and still nothing is coming out of the adapter box.
The good news is that the laptop is probably fine, but there is a break in the output cable somewhere, or the supply itself is broken.

The best thing to do would be to see if it is still covered by the warranty, and get a replacement.

If you have some basic electronics skills (strip wires and a bit of soldering), you can cut off the connector, and see if anything is getting that far along. If there is a voltage there, the connector is broken, and you can buy and fit a replacement for about £1.50.

If there is no voltage at the end of the cable, you could cut it off at the supply and check for a voltage, but you will end up having to buy a new cable, and will have some joins in it.
Kiteman6 years ago
Sounds like a dodgy connection somewhere the transformer box of your power supply and the socket on your laptop.

Try taking out the battery, then plugging in the laptop. If the laptop runs, then the problem isn't the power supply.

kenizl86 (author)  Kiteman6 years ago
Well, I took out the laptop battery, then reconnected the power cable and tried to turn on the computer, but it didn't come on.
So, that's (in order of probability):
  • A connection come loose in the socket of the laptop.
  • A dodgy connection at the other end of the power cable.
  • A broken lead in between.

Next test - borrow a power lead from somebody else.  If it works, your power supply is dead.  If it doesn't, it's the socket.


kenizl86 (author)  Kiteman6 years ago
I don't really have anyone to barrow a power cable from, especially a Dell.
I'm out of ideas, then. Sorry.

Let's hope somebody else can help.