Instructables

Laptop Speakers Broken ?

Hello, everybody. I have a problem that is really driving me crazy and I was hoping that someone could help. The sound has gone out on my HP dv6131. At first I thought it was just a Vista issue, as the computer originally came with XP, so I tried updating all the drivers that I could could think of (Conexant), but none of them helped. Next I plugged in headphones and realized that I can get sound through my outputs, but there is also no input through the internal mic. I can however plug in a mic just like I can headphones or external speakers. When I go into the control panel and play music the mixers show that everything is working. I'm sure it's the speakers, but I'm really hoping it's something I can fix. I just have no idea where to start. Will someone please help. I have worked myself into delirium with it and I am desperate. Thank you.

zack2473 years ago
have you fixed it yet? it may just be worn out speakers, i have a gateway laptop that the left channel speaker didnt work, so i wired in a new one and it works great now.
DANKILL1 (author) 5 years ago
Thanks alot, I'm heading into work and try this as soon as I get back. I'll let you know how it goes
DANKILL1 (author) 5 years ago
I went through the steps , but to no avail. I really think you may be right about the SPDIF, I just don't understand what to do. When I do the sound test for the internal speakers/headphone tab with the headphones on I get sound. Without the phones I get none. When I test the sound on the SPDIF I get no sound either way. I have tried to just disble the SPDIF but that doesn't help either. Also when I go to the recording tab the Wave Out Mix/ Conexant High Definition Audio says currntly unavailable. I really appreciate your help and am willing to try just about anything at this point. So if you don't mind then keep the ideas coming. I'm going to try and do some research on SPDIF at the HP website too. Thanks again
I found another support page from HP here. It describes how to resolve a no-sound problem after switching from XP to vista or vista to XP.
This is a somewhat common problem. Try what HP says before taking any further steps.
DANKILL1 (author)  plane phanatic5 years ago
Well, I tried all of the troubleshooting on the page and updated my drivers again butstill no luck. It also advised me to update my BIOS, but every time I tried it kept giving me an invalid file name error report and wouldn't allow it.
The solution is listed here. The problem is most likely that your audio is set to SPDIF. This should be unchecked. To do so, you have to scroll down to where there is a header that says Solved: no sound problem Vista.
DANKILL1 (author)  plane phanatic5 years ago
I'll check that out. Thanks alot for replying.
Pro

Get More Out of Instructables

Already have an Account?

close

PDF Downloads
As a Pro member, you will gain access to download any Instructable in the PDF format. You also have the ability to customize your PDF download.

Upgrade to Pro today!