loading

Laser Cutting Machines

I recently installed a Chanxan CW 1610T Laser Cutting Machine with two 95W CO2 laser tubes. Everything works including the cooling system, pumping system and the fan. I turned on the machine and turned on the two lasers. The thing is when I press the Pulse button on the control panel, none of the laser tubes fires. I want to adjust the optical path and I cant do that if the Pulse button has no response. When the machine is ON, the ammeters show a 0 reading and there is no deflection. I thought it was a Laser power problem so I removed the data cables on the laser power box and when I press the test button on the box, the lasers fire beams. So help me out and suggest if its a setting I have missed or something else cause the machine is preventing production to start.

Picture of Laser Cutting Machines
Photo0005.jpg
the Ammeter values read 0.jpg
The whole machine is ON, Laser shows no red light or power.jpg
sort by: active | newest | oldest
Kiteman1 year ago

I had this issue - I just pressed "escape" before pressing the pulse button.

Also, the pulse won't (shouldn't) fire if the lid is up because there is a magnetic reed switch that only closes when the lid is down. If you need to trigger the pulse with the lid up, put a small magnet on the reed switch.

TendaiM2 (author)  Kiteman1 year ago

Thanks Kiteman. I have tried pressing the ESCAPE button and then PULSE button but nothing comes out. The machine tool cover lid is always closed and the only lid up is the one that houses the tubes. Also when I remove the data cable from the laser power supply and press the TEST button on the power supply the laser fire

TendaiM2 (author)  TendaiM21 year ago

Maybe I entered the wrong settings and if you can suggest me the proper setting I should enter cause the machine is only going to be used for cutting fabric

You bought a 95W laser to cut fabric? Wow.

Mine is 40W, so our settings are going to be very different - I think you're going to have to get in touch with the supplier/manufacturer for better help.

TendaiM2 (author)  Kiteman1 year ago

Well I wasn't part of the team that did the procurement you know how it is. The lasers are now firing and I just need to adjust the optical path

Good luck - it can be quite fiddly.

(I've never seen a cutter with two laser tubes - do they both fire at once?)

I think I can arrange for a tour of the Death Star. Prepare to be impressed.

It seems a big part of getting high tech gear like this is the customer support you need afterwards to get it up and running and for ongoing maintenance. Pop a fuse and you may be down for months.

That's why I bought from a small UK supplier* - they were able to show me one of their cutters working, and were available with email help exactly when I needed it.

Should the worst come to the very worst, they're just a couple of hours' drive away...

* http://justaddsharks.co.uk/