LilyPad Arduino USB - ATmega32U4 Board - Not detected on PC

I have a lilypad arduino usb - atmega32u4 board and when I plug in via USB on the PC (Windows 7) nothing happens. There is no sound from windows that something is connected. Nothing under Device Manager. I tried reinstalling Arduino IDE but still cannot detect the lilypad.

Any suggestions what could be the problem?

SakhumziS (author) 2 years ago

Sorted the problem.

Reason : the switch must be in the on position as opposed to the CHG position. It is easy to miss the button.

SakhumziS (author) 2 years ago

This is the "lilypad arduino usb - atmega32u4 board"

LilyPad Arduino USB.jpg

Not researching the product and the Arduino webite seems to be the problem.
a) you will dinf detailed infor about your Lilipad there
b) it would have told you that you havea "naked board" and to connect it to the computer you would need an FTDI board
With nothing on the Lilipad that would be able to connect to a computer it is no surprise it does not show up in Windows ;)

Instead of the suggested FTDI board any suitable Arduino can be programmed to used as a FTDI programmer - if you have a spare that is not a (currently) useless Lilipad.
For example I use a spare Arduino Mega for my my FTDI needs, no only for Arduino based devices.
I suggest you start on the official website:http://www.arduino.cc/en/Guide/LilyPadWindows and work your way through the installation process.

SakhumziS (author)  Downunder35m2 years ago

Thanks for your email. The new "lilypad arduino usb - atmega32u4 board" does not require the FDTI (https://www.sparkfun.com/products/12049#comment-5562e2f2ce395f98718b4567). The suggestions on the website:http://www.arduino.cc/en/Guide/LilyPadWindows are not based on the new board.