Noisy pot issues?

Hi, I've been experimenting with a variable output power supply. It takes 18V @ 2amps in from a wall adapter. It uses the LM2596 simple switcher as a regulator. My circuit is more or less the same as the test circuit from the datasheet (image attached). The only thing I've changed is that R1 is a 5k trimpot and R2 is a 50k 10-turn pot. The trimpot is so I can dial in the proper value for R1 and the other pot is to vary the output voltage. It works more or less as it should. The one issue I'm having is I think due to the inherent "noisiness" of potentiometers. When I turn the knob (sometimes it seems when I just touch it), the output voltage will "spike" up. It eventually falls back down to where it should be and stays steady, but it seems to spike everytime I adjust it. Does this indicate a bad pot? Or is there some additional filtering circuitry I can put to avoid these spikes or ripples? Would another L-C filter help? Thanks in advance,

Picture of Noisy pot issues?
deadbilly (author) 9 years ago
Thanks. I'll double check the connections. I'm pretty sure there's no ground loop going on. Also, it seems to have worked well in the recent past. I'll clean the contacts and try it out. I just wanted to make sure there was no weirdness going on. The datasheet says a lot about lead length and RFI/EMI stuff as well as feedback loops. I've mostly ignored that stuff so I wasn't sure if it was something obscure going on.
Goodhart9 years ago
Hmm, the 10 turn is a precision pot I assume. Is there any chance you are inducing a ground loop when you touch or grasp the pot ? Or maybe that is the source of the noise...I have seen stranger things happen from simply "touching" something (I had an FM radio I could change stations on by touching the plastic volume knob *shrug*)
NachoMahma9 years ago
. Sounds like a dirty pot to me. Try hosing it down with contact cleaner while turning the pot. I like to give the a shot of WD-40, but a lot of ppl think that's a bad idea.