Instructables

Parsererror during image upload

When I try to upload images to an instructable I'm working on, I'm receiving a "parsererror" and being logged out of the system.

This is my third attempt to reply to my original comment. I've been kicked out the last two after trying to attach an image of the error screen. It attached fine, but when I hit "post comment" it flashed an error message too fast for me to read then went to the login screen.

In my prior comments, I said I've also tried to restart the entry and still encounter the same error. I've seen other postings regarding parsererror (I misspelled it earlier), but I've already tried to start over and I suspect my inability to post even a picture to this comment is related. How can this be corrected?

The error says, "There's been a problem updating your Instructable. parsererror SyntaxError: Invalid Character"
What that message means is that you've used a character that the system basically can't process because it interferes with the actual behind the scenes code that make the functions on this site possible. The offending symbol/character might have been used in the keyword tags you're trying to attach to the image file, or could be in the Instructable itself. When you add photos, the website has to save the file and when you select to "add" it (or you used the checkbox to automatically add it), the website has to save your Instructable; so the error might not be with the image itself, it could be with the text you added just prior to the image.

The other thing to be aware of is there are known issues (with many scripts which are not specific to Instructables), associated with "copied and pasted" text, especially from programs like MS Word. It's best to only copy and paste using a "plain text" editor because they use a simple character set, and don't use a lot of "non-printing" characters that other text editors use. So although you might not even see the characters, when you select "HTML view" from one of your button options in the Instructable editor, you might see what I mean.

So to fix the problem, you should go over your text and remove the character(s) that might be causing the problem and try and save the file. You should continue to get errors as long as a problem exists. If you don't see anything that you can remove, then copy all the text and open note pad (for Windows) or text edit (for Mac), and paste the text into the editor. From the menu, ensure that the text is set to "plain text". Then re-copy your text and paste it into your Instructable and save it.

I hope that information is helpful. It shouldn't have anything to do with your problems with "disappearing comments". Unfortunately, that issue has popped up in the past few days and is being addressed.
Okay, I'll give it a try. Thanks for the help!
Pro

Get More Out of Instructables

Already have an Account?

close

PDF Downloads
As a Pro member, you will gain access to download any Instructable in the PDF format. You also have the ability to customize your PDF download.

Upgrade to Pro today!