loading

Picture Bug

When I try to click on a photo after the first people provide to show the steps, it continues to show the first photo and none of the ones I click. It's almost like a broken link but it has to do with a setting on my computer and have tried to fix it but can't figure it out. I'm running a windows 7 machine and Firefox 9.0.1.

sort by: active | newest | oldest
1-10 of 20Next »
Kiteman5 years ago
Any chance of a screen-shot or the URL of the project(s) this is happening on?

That's the kind of thing that helps the development team so much that they give away pro memberships...
mdstb (author) 5 years ago
OK, figured out what was going on with my system. Not sure if this is what's going on for the others, but "NoScript" add-on for firefox was disabling the scripts for the pictures. Even after I gave permission for the whole site it was still doing it, so I disabled it and restarted firefox, then re-enabled it and tried it. Works fine and no longer an issue.
splash5 years ago
[SOLUTION]. I use the no-script add-on for Firefox. Clicking thumbnails functionality is restored when allowing doubleclick.net to run scripts. It's seems that some of the functionality has now been tied to allowing advertising?
ksexton1 splash5 years ago
I'm also having the problem, on firefox with adblock plus. I unchecked the one rule for instructables, no change. There are many rules for doubleclick.net, not seeing which to disable, and trial and error isn't getting me anywhere yet. If I turn off adblock plus, the site works, I only installed it anyway to stop some ads on a live ustream that I watch, where each ad meant a missed portion of the video.
Anyone have any tips on how to find the rule that messes with the pictures here?
fzumrk ksexton15 years ago
The Adblock plugin for Firefox appears to be the culprit. You can disable it by clicking the Adblock icon and selecting "disable on instructables.com".

Alternatively you can add a filter rule by clicking the Adblock icon and selecting 'filter preferences'. Select the 'custom filters' tab and select 'exception rules'. Click the 'add filter' button and fill in the following for the rule:

@@||www.instructables.com^$document

Make sure the 'enabled' box is checked. Close out of the Adblock preferences window. You may have to re-start Firefox before the changes take effect.
ksexton1 fzumrk5 years ago
@@||www.instructables.com^$document that worked, thanks
gmoon fzumrk5 years ago
Yep, there's been some scripting changes here, and Adblock Plus (and possibly NoScript) are interacting with the site at some level.

Personally, I won't be disabling either (I tried that once after being promised there would be no autostart ads, but then the Craftsman ads hit).
Thanks for mentioning the 'advertising' bit. This was driving me nuts, but when I saw that I thought - wait, I just added AdBlockPlus! Disabled on Instructables and now problems! Thanks!
Super_Geek5 years ago
Confirmed, Ad Block now blocks the changing of images on pages with more than one image.. If you disable it in add-ons the images change again, but this is not a real option.
I don't have any scripts from doubleclick showing up in noscript. Disabling adblock does not help. And I'm not leaving noscript for one site :(. This is sad, because quite a lot of the instructables gets really confusing without the rest of the pictures. Fix this, and I'll be back on instructables!
1-10 of 20Next »