Problem with my variable regualted dc power supply.

I have a used variable voltage regulated power supply that does not work ; when i turn it on, the Volt meter tops, and if I switch to ammeter, it shows 0amp, if i plug a voltmeter on the female banana plugs there's no juice... I've checked the fuse, it is not damaged. i've also checked to potentiometer with my ohm-meter looks like it's working normally. I don't know what is wrong with it... Do anyone have any idea ?

sort by: active | newest | oldest
1-10 of 12Next »
Sandisk1duo8 years ago
was it home built or did you buy it from a store? Ammeter is has a tiny amount of resistance, so you would be shorting the power supply how did you check the fuse? Digital multimeters (dmms) with a blown fuse still read resistance and voltage
lordofthedonuts (author)  Sandisk1duo8 years ago
It was bought from a store. I've checked the fuse by eye, I just looked at the tiny wire in it to see if it was burned, cut or damaged, Am I doing it wrong ? I don't think the ammeter would short the power supply since it was was bought from a store. Thanks.
. I think a-s was talking about your handheld ammeter, not the one on the PS. . Speaking of which; if the internal ammeter is open, you won't get any output. Short across the ammeter terminals to bypass it. (Do NOT short the voltmeter!) . . Start at one end of the circuit and work your way to the other end, taking readings to see where the fault is. Since you don't have power at the output terminals, trace back until you find a point that does have power. The stage following that point is probably bad. Or start at the rectifier and work your way forward - when you get to a dead spot, the previous stage is probably bad.
yay, i got a nickname now !
um.. ok, you'll need to check the fuse some other way, like with the meter, for resistance (dmms still work ok w/o fuse to measure resistence) The ammeter has like >1ohm resistance, so if you connected the meter stright on to the power supply, you are putting >1ohm resistance load on the power supply. the power supply probably has a safety feature that shuts it of when the load has >1ohm resistance maybe check for a fuse on the power supply?
lordofthedonuts (author)  Sandisk1duo8 years ago
Wait, are you talking about the fuse on my DMM ? Because I was talking about the fuse on my power supply....
oh ok, the fuse on your dmm might have also been fried, check that
set your multimeter to ac volts (whatever voltage it has higher than 1.5X your line voltage) connect the voltmeter between 2 points on the input move the voltmeter leads from the entry and into the circuit untill you see there is no more voltage. move both leads and not just one after the transformer use still the ac setting. move both leads at once from the entry to the exit of the transformer after the diodes you should switch the multimeter to dc. again move both leads at once from one to other side when working on the high volt side (before the transformer) do not hold the test leads in your 2 hands and stick them in the supply - you can touch something with 2 hands and get a big shock. unplug the thing and move the leads when its off
lordofthedonuts (author) 8 years ago
I just noticed something strange, there's capacitor soldered between the positive and negative lead on the banana plug, I don't know if it was the preceding owner that soldered that here.... (It's a 220uf 50volt)
. That is most likely a filtering capacitor. If it is burnt looking or bulging, it's probably bad. . The PS should work without it (but you will have some ripple), so unsolder one side and see if it helps. Probably won't, but it's worth a try. If the PS starts working, replace the cap.
1-10 of 12Next »