loading

Questionable website

I'm getting the feeling the people running this website don't really care about fixing it's problems, twice now I've tried to post a new topic and it fails to even show up, if these problems are not fixed and my 3rd attempt fails I will be contacting admins to remove my content.

sort by: active | newest | oldest
seamster1 year ago

Sometimes contributions to the site (comments, forum posts, actual instructables) get stuck in the site's filters for a variety of reasons.

Upon review, the admins will either shoot the items live, or if they are deemed spam or overly promotional in nature, the items will be removed.

Toga_Dan1 year ago

Sometimes it takes hours before a new topic shows up after posting.

Kiteman1 year ago

Since you've been able to post this topic, I'd guess the problem is fixed?

If not, it may be due to the recent major updates - try clearing your cache and get rid of old cookies.

Moem1 year ago

I prefer to see the website as 'quirky', rather than questionable. Sure, there are bugs. No one is going to deny that. But I'm not paying to use it, so I'm not too worried.

+1 'wonky'

This and replies to posting are disappearing into the digital nirvana for quite a while now.
A big deal of it was already solved.
But between 2AM and about 5AM local time here I do not bother to post anything as I sometimes forget to copy what I typed before hitting the button.

Let me guess: You are done, you pressed the button, it faded out but nothing at all happened.
After about 150-25 seconds the pages pops up fresh as you just loaded it - without your comment.
Does that sound about right?