loading

Quicktime ate my YouTube!

I recently installed a new update of Apple's Quicktime. After this, I found that I couldn't watch videos online. (Via YouTube, Metacafe, etc.) In the video's place, I get a Quicktime logo with a white question mark. The same for flash-based interfaces, etc. After extensive google-ing and forum browsing, I still haven't found a solution to my problem. I know several other people that also have this problem, and they've always reported that it began after installing the latest update of Quicktime. So, I'm thinking it's a problem that affects a lot of people, and I'd like to post the solution so that it'd be easily available to a large audience. That, and I'd like to have a place to link to. Yay for Instructables! So, do any of you know how I can fix or work around this issue? (I’m well aware that there’s probably already a solution posted up somewhere, but I must be lacking the appropriate search terms).

Picture of Quicktime ate my YouTube!
InstructablesError.bmp
sort by: active | newest | oldest
Punkguyta10 years ago
uhh...why did you install quicktime???? Uninstall it, then download the K-Lite Codec Pack , then install that, and if you choose, download VLC player. That thing plays everything, all quicktime files aswell, you just need to have the codecs to play quicktime files. The player tends to screw up pc machines, sometimes even on the macs, like my ibook. What it's doing is that you have it set on file associacion for all files, so it's basically trying to play a .flv file (the flash video proporiety file type that youtube uses), of which nothing that I know of can play that file, it can only be converted with a program to something like a .avi. So I'd say, try at least uninstalling quicktime, and if you need to play quicktime files, then try my links and see if that works for you.

Also, if it installed with itunes, then you can uninstall it, last time I ever used itunes on a pc, I was able to uninstall quicktime without a problem and itunes still worked.
carbon (author)  Punkguyta10 years ago
Uhh...Why did you install Windows? Uninstall it, then download Linux. /Linux Snob-ness. :P

My theory is that Quicktime is messing with certain settings, and making itself the default flash player. However, I don't think it knows how to handle flash all that well, so it errors when it comes into contact with certain flash interfaces. Ie, YouTube, Metacafe, GoogleVideo...

Of course, I'm assuming that those things run on flash. Could someone confirm this? Or, more likely, smack me upside the head for being stupid? ; )



I already have those programs installed, and they're awesome. Especially VLC, it plays Everything, with a capital E. However, sometimes a given program will require an installation of Quicktime. I don't know how to get around that, and I think it's more convenient to just install Quicktime.

Punkguyta carbon10 years ago
Quicktime has no support. I have an ibook g4 if you paid any attention, quicktime only takes care of mov files and .avi files, but the sad thing is that quicktime can't decode anything more than the default microsoft avi codec, coded files. Safari has a built in flash player and that's how it uses flash.
carbon (author)  Punkguyta10 years ago
I have an ibook g4 if you paid any attention

Sorry, I was trying to imply that the subject of the first sentence in your first post could have very well been replaced with Windows. I was poking fun at your question. Like, you wonder why I would ever install Quicktime when there are better options available. And..- Well, look, just forget I said that. ; )

And, in the following section, I was trying to make it clear that despite Quicktime's suckage (Of which I am well aware), it still gets used, and sometimes you just have to put up with it.
Punkguyta carbon10 years ago
Well I just don't understand the need for it. The klite codec pack has all the codecs you would ever need, quicktime is just "Sticky" and hard to stop it from starting with the computer.
LasVegas10 years ago
Don't uninstall Quicktime. That's not your problem. All you need to do is go to the Quicktime Control Panel and turn off Flash support. Your computer will revert back to using the installed Flash player. BTW: It's the fact that the Flash Player is installed, that Quicktime has this problem.
carbon (author)  LasVegas10 years ago
Strange, I thought I did that. ; )
QuicktimeSettings.bmp
LasVegas carbon10 years ago
I believe it's also enabled/disabled in the Advanced section.
carbon (author)  LasVegas10 years ago
Am I missing something here?
QuicktimeSettings2.bmp
LasVegas carbon10 years ago
Nope! You've got it off. In your browser, check the plugin list and see what's activated to handle Flash. If nothing appears, reinstall Flash Player.

To do this in Firefox, go to the address about:plugins and you should see something like:
Picture 2.png