loading

Rapache- What's up?

How would i go around fixing this so that it starts up?  If you look at the bottom of the screenshot it says, "Warning, cannot connect to server"  What server?  How could I fix this and what does in mean?

Picture of Rapache- What's up?
sort by: active | newest | oldest
1-10 of 19Next »
tanmanknex (author) 7 years ago
okay, so i got that message to disappear, but now the site won't load.  when i try to access the website, even from within rapache itself.  I think it might have something to do with the ports in the config files.  I need to change the port to something other than 80, and when the listen isn't 80 it shows the message in the main post.  What should i change in the three files attached to change the ports?  rapache's files say that if you change ports.config you have to change 000-default also.  default is another file that i thought i should attach.  any help would be appreciated.
Screenshot.png
ports.conf513 bytes
000-default948 bytes
default948 bytes
.  I suggest leaving the port set to the standard 80 - at least until you get the kinks worked out. Everything should work out-of-the-box - if necessary, re-install everything and work with the defaults.
tanmanknex (author)  NachoMahma7 years ago
my isp routes port 80 to our modem, is there anything else that i could do?
.  How does your ISP route anything on your LAN? Especially on the same computer?
tanmanknex (author)  NachoMahma7 years ago
What i mean is that they block me from serving on port 80.
.  I still suggest that you get it running with the default 80. Once you can pull up a page by using http://192.168.0.1/ (or whatever your local IP is), then change to a different port and see if you can access the server remotely.
.  http://localhost/  may work.
Or http://127.0.0.1/ -- like NachoM I'm assuming you're running it locally (on the same machine.)

Question: Is the server actually running? (the "httpd" daemon?) You have to explicitly enable Linux to run a service...
> assuming you're running it locally
.  I was going by the "Document Root: /var/www" from the graphic in the OP. But there could be a Base URL setting somewhere.
.
.  Sounds like there's a good chance the server isn't running. I'm not very familiar with *nix; can you tell him how to find out if the server is actually running or not?
Try listing all the processes (best to do this as root; or use sudo):

ps -A

if httpd is running, it'll show up there.

"Document root" is on the host machine--the file location that will act as the http protocol root (http://). It's defined in that "default" file. That, and the other config filse indicate that the server should be listening on port 80.

Re: starting the service-- it will depend on the particular Linux variant. Might as well do it the easiest way possible... I'm not familiar with Rapache, but it does look as it can start/stop the server, and show the status.
1-10 of 19Next »