Instructables

Raster Graphic Editors (e.g. photoshop) Don't Like Filling


I've been having a bit of a dilemma with raster graphics editors such as Photoshop and GIMP. In either of the two programs, when I draw a solid line, it automatically fades the edges. This normally wouldn't bug me, except I need to fill in these areas. Whenever I do so, the area I fill in doesn't do so entirely because of these faded edges. Does anybody know how to make either Photoshop or GIMP stop doing this and fill in the entire area?

gimmelotsarobots (author) 2 years ago
Thank you. That fixed the problem in GIMP, I'll have to look for similar settings in Photoshop. It seemed to work best at around 140-155 for thick lines, and 120-130 for thin ones.
drknotter2 years ago
There's definitely a way to do this in GIMP. I'm not sure if it will work under all circumstances, but using the example you provided, I got it to work.

If you look in the tool options dialog for the bucket tool, you should see a "Finding Similar Colors" section. Check the "Sample Merged" box, and turn the threshold (it's a slider) waaaaay up. I set mine to about 130. What this  does is fill colors that are "close" to the color that you clicked on, "close" being defined by the threshold slider.

Hope this helps! The first image is of the tool option dialog, and the second image is a picture of the result, just to prove that it works.
Screenshot.pngScreenshot-1.png