Rex C100 temperature controller - changing settings

I recently ordered a REX C100 for my electric melting furnace project.
As it came already with a SSR and temp sensor I only added a sensor capable of reading more than 400° of the supplied one.
These controller are dirt cheap and have lots of support in the modding community - although you now can get them new in all variations so no more modding required.
Internally they run on 12V DC, so even mobile use is possible (but this time after modding).

My problem with this controller started with the not included manual.
As it is no China clone but an original from RKC Japan, I downloaded their manual and tried to adjust the max temp settings as well as changing to the thermocouple.
To my surprise the menus for that simply did not exist on my model.
Reading a few more manuals showed that to get to the "initial or factory setup" you need to change the lock code.
Here things get confusing:
Once in the lock menu setting most manuals state to enter "0000" to activate the hidden menus.
(Mine was alreay on 0000)
Others state to set the code to "0100".
In any case you have to hold the setup key for a few seconds to store the changes and after that hold the settings and shift key for about 5 seconds to enter these factory menus.
After being close to send the unit back I tried different code combinations and finally found that "1000" actually activates the hidden menu on my model!
But again there was no joy as several vital settings still did not show up.
To finally get all settings another step is required:
The first item in the hidden menu is "CODE" and it shows as "0000".
After changing this to "0001" the setup key can be used to get to the settings to change the max and min temps.
Once all this done the controller actually shows the selected sensor and if Celsius or Fahrenheit is used at the start and from now on simply by clicking through the hidden menu with the setup key you can get to the min and max temp settings again.

I hope this info will help someone running into the same brick walls as I did...

sort by: active | newest | oldest
1-10 of 25Next »
priest771 year ago

I've ordered from ebay my second c100 but this one is "Berne REX-C100" and the menu differs from my old "RKC REX-C100".

Problem is that I need it to show me decimals of °C because I am using it in my egg incubator. I have PT100 (thermocouple) and I want to use it instead of the K type thermocouple that came with C100.

When I power it on in shows me:

C04

and then

K

999

Then when I enter in settings menu I have this (all with only 3 digits values):

AL1 (050)

SoH (999) this one is locked

ATU (000) this one is locked

P (030

I (240)

d (060)

Ar (025)

T (020)

SC (000)

LCK (000)

When I change LCK to (100) I get:

SL1 (000)

SL2 (000)

SL3 (000)

SL4 (001)

and here in SL(x) everthing is locked except SL4. I think that if I could unlock SL1 that I can change the thermocouple type, but how?

Hello, I've recently bought a Berme REX-C100FK02-V*AN by Banggood and got the same settings and same problem. They do not really answer to all my questions, especially what is this SoH parameter for. By me the SoH is not locked, and I can change the value, but I do not see a significative changing if I set it to 000 or 999. I have to dig a bit more on it.

The model I've got can not work with resistive sensor like Pt100, it is
normally fixed for TC sensor and is calibrated to the K sensor provided with it. The SL1 can not be change. For this, as fare as
I've seen, a hardware setting must be done. I'm going to try this way to
see how it will work.

Anyways, by trying key combination, I found the sensor calibration (I assume it is). Be careful to not do it unless you know what you are doing, otherwise you are going to lost the calibration made in the factory ! If you have some mV generator it might be possible to change this calibration for an other TC type (not tried yet).

Only for info, again do not make it if you can not correctly recalibrate the unit !

Sensor calibration :

Push Down and Set key together >3s. At this time you will see LAS, which I assume is the Lower Analog Span calibration point, on the upper display (red) and a value on the green display which is the actual reading value from the sensor (you can see changing if you heat or cool the sensor). Generate the 0°C correct value (see bellow) and push Set key to accept and go to the HAS parameter, which I assume is the Higher Analog Span calibration point. Here the correct mV value should be generated (see below). Key Set to accept and come to a CAS parameter that I do not know what it means. Key Set again and come to the normal display.

I've been playing a bit with those parameters and saw how they change the calibration. 1st the LAS and HAS value are figure value and not the real temp.

The LAS does not give 0 when the input is 0mv, but it shows 64 (in my case). To have a 0°C displayed in normal mode, the LAS value, for my instrument, is 83, means an input of 1.3mV. For the HAS, it seams the target value is 430°C (don't ask me why, but it's what I've found). So a K sensor type at 430°C gives 17.667mV (regarding TC tables). If you put a 17.6mV, HAS shows 395, and this will display 428°C in normal mode. We are quite near. The CAS does nothing for this instrument.

Regards

Bricola55, how are you generating this mV input to the PID, mine it's not calibrated, this SET + DOWN, mess with all the calibration and guess what: I found this hidden menu before knowing what it does.

I'm planning to generate this aproximate temperatures to try to roughly calibrate the PID again.

Please, can you describe your equipment?

Downunder35m (author)  Bricola551 year ago

Thanks for sharing!
I know chinaman changed the REX100 models a few times but the latest changes seem to affect what we were able to do before.
Anyway, I can not really recommend a manual "calibration" of the sensor values, this should be performed through the automatic routines where possible.
Only if you have all vital parameters for a probe you might be able to find the corresponding values through the manual calibration.

I am still quite sure there is a way to get to the code settings as in previous models but now it might be required to use software or at least access to the programming.
Why do I make this statement if it seems noone is able to do so?
Quite simple: I have seen these newer Rex models with different sensors and temp ranges offered online.
One even for incubator use with a temp range of just 25-45°C...
I am reluctant to order one as I don't really need one right now and would not know what model variation I get.
It could be as simple as pressing the right buttons together or doing so while switching on - quite a few devices alow access to hidden parameters only during startup.
Could also be that two testpoints need to be shorted on the circuit board (or extended outside to a switch).
Worst of course would be the real need to access the programming part.
But maybe your insight will make other people try, try again, and then some more to find out how we can access them.

Hello, as you can see on the picture of my Breme Rex-C100FK02-V*AN, the selection between TC and RTD is now made at the hardware level. I'm going to test this to see if only the bridge selection is enough or other adaptation must be performed.

I've also been trying a lot of key combination at start-up and during normal running without finding the Grail. I won't give up, but chances to find out begins to fade.

I think they really have made thinks more complicate and lock access. There is may be a possibility to come into the program itself, look at the 4 pins contact near U3 (that is of course without type, number or code on it). I'm not at the right level to go into, may be someone else can.

Mode TC et mode RTD - Harware selection.JPGTC Input and relay Output logical Board .JPG

Hi, did you test this? I have the exact same problem, and after opening it up I'm very tempted to just go ahead and cut the three TC bridges and soldering up the three RTD bridges. I'm kinda worried about calibration, though, as RTD Pt100 probes come in a variety of ranges, and I'm not sure if the kind I have (-50C-500C, 1/2" NPT threaded detectors) would even give a temperature in the ballpark of what's correct.

After the LCK setting my Berme Rex-C100 gives:

oH (002)
According to some manuals it sets the differential gap

In my understanding it's about the limits of regulation.

Factory setting is 002, which should mean SV plus or minus one degree.

Anyway my system overshoots sometimes more than 1 degree; enough reason to order a genuine RCK PID with Pt100 probe.

Downunder35m (author)  nixmit1 year ago

Overshooting can be a simple cause of a wrong PID setting.
I would try the autotune function first.
After changing settings it is often required to do this.
Especially if the object in question is quite big or heats very fast.

My comment was about the Berme Rex-C100, which is a (too) cheap imitation of the original RKC PID.
As you can see in priest77's post, the Atu setting is blocked.
So I fumbled around with some other settings, but the final solution must come from my newly ordered RKC Rex-C100. ;-)

Downunder35m (author)  priest771 year ago

There might be a similar way to unlock the menu on your model but:
Even with a different type of thermocouple it won't be any good for eggs.
Been there done that, moved on.
Even with modified pid values the controller will have over 2° of fluctuation, which is pretty good for heating other things but not nearly good enough for incubating.
You need betwwen 37.8 and 38.2°C for the eggs with changing temps during the different stages - no chance to get that accurate with a REX.

1-10 of 25Next »