New Instructable fails to publish

Whenever I am trying to publish a new instructable, most of the time I am getting the error message that "The Servers are busy. Please wait a few minutes and try again"

However, if I go to my page, the instructable seems to be published. If I tried to publish again after entering in a contest, I get 2 emails that say my contest entry has been received.

Please see the attached screenshot 

Picture of New Instructable fails to publish
sort by: active | newest | oldest

Me too, I had the same error and could not enter a comp for 3 days.

Matlek3 months ago

BTW I also got some problems entering the "fidget spinner design contest", when I clicked on the "publish" button nothing happened... So I clicked many times, then gave up. But few hours later it has been accepted in the contest and now it is available. The only problem is that now on my profil you can see that I have published 5 times the same article!

Yonatan24 Matlek3 months ago

I see it once.

I think I had a similar problem with my last I'ble (published June 22nd), but I can't remember exactly what. I think it didn't let me publish too...

Matlek3 months ago

I got similar problems... In my case I also got the same message "The servers are busy...", then received the emails for the contests and I was wondering if it was published or not. Then after a few hours it was available with the other "recent" articles. So I'd say wait a few hours and it should be okay!

BrittLiv3 months ago

I have been having a lot of problems the last few days, as well.