Text entered into Instructable DISAPPEARS


This is a problem I've been having for a while now.  When writing up an Instructable, I typically write all the text, then go back at a later date and add pictures.  Several times now, I've added pictures to a step, clicked to the next step, then THE ENTIRE BLOCK OF TEXT IN THE NEXT STEP DISAPPEARS.  I do not use all-caps lightly.  The text is irretrievable - I have to rewrite it from scratch.  Not only is that a huge waste of time for me (since I don't have any time to spare), it also results in an inferior duplicate of what I'd originally written.  Details are skipped, ideas forgotten, etc.  Chances are I originally wrote that text days or weeks ago, when the information was fresh.  Now it's stale.

Please, please look into this.  I've taken to copying everything into Word as "safe keeping" until the Instructable is published.

Computer details:  Mac OS X 10.5.9, running Firefox 3.6.12 (though it happened with previous versions of Firefox, too).



Picture of Text entered into Instructable DISAPPEARS
sort by: active | newest | oldest
1-10 of 14Next »
player27566 years ago
Yea I had the same problem, with the same solution.
jeff-o (author)  player27566 years ago
Good to know. What OS/browser are you using? Are you able to force the error to happen?
Firefox, vista and win7 depending on what lappy I'm on. I wouldn't call it an error. It's more of a navigation problem when using the back and forward button on the browser.
jeff-o (author)  player27566 years ago
Ah, so it happens with forward and back buttons, for sure then? I was second guessing myself, thinking it was just photo rearranging that did it.
jeff-o (author) 6 years ago
Here are some other people who experienced the same thing:

https://www.instructables.com/community/Ible-text-disappears-permanently-during-editing/

https://www.instructables.com/community/Intro-step-text-disappears-from-published-instruct/

jeff-o, I've been trying to recreate this problem since I saw this post. I'm unable to recreate it, which makes it difficult to pass on specifically what's going on. We're thinking it might be a problem when working on instructables with a lot of steps (we noticed there were 21 in the image.

Do you find you have the same problem with shorter instructables?
Can you force the error to happen with any consistency?

It's really difficult to nail down a bug when it only happens to what seems like random users only occasionally.

Please let me know anything you might have to help track it down specifically. Does this only happen in a specific internet browser? Does it only happen on a specific OS you use?

Thanks!
Hi, Matt. You may be interested in a similar bug report...

https://www.instructables.com/community/Intro-step-text-disappears-from-published-instruct/
jeff-o (author)  StumpChunkman6 years ago
I'll give you the details I have. I only ever use Firefox to edit my Instructables, and usually the latest one at the time. I've had it happen on both my mac running OS X 10.5.8 and on a Windows PC running XP.

I noted specifically that it happened when rearranging images. There were maybe 9-12 images attached to the specific step. The screen refreshes (goes white then comes back) and the text is gone.

This happened with both my Galileo's Bicycle and Woodpunk Lamp instructables, which are both fairly image-laden. I wouldn't say that 20 steps is a lot though. My memory is fuzzy but I think I noted the issue on even earlier instructables but I can't remember which.

I haven't tried to force the error, but I could try. I've got a few in-progress instructables that I could mess around with. I don't want to touch anything I've already published.

Should I be giving Firefox a bigger cache, maybe? It really would be good to know exactly how many others have seen this problem.
Jayefuu6 years ago
I've not had _this_ problem, but sometimes the first step loses its content :( Not been able to work out why or when yet.
jeff-o (author)  Jayefuu6 years ago
Yeah, it doesn't seem to matter which step for me.
1-10 of 14Next »