loading

Touch switch circuit not working?

Hey, i'm making a touch switch for a USB powered desk lamp, and the touch switch isn't working. The circuit diagram, layout and pictures are below. I used the circuits from the following two websites to design the circuit: http://www.talkingelectronics.com/projects/TouchSwitch/TouchSwitch-1.html the 4th circuit.         http://www.zen22142.zen.co.uk/ronj/tg1s.html 

 

 I've joined the output of the touch switch to a transistor that should activate the toggle. But the output of the touch switch appears to be constantly on. Can anyone see a problem with my circuit design or circuit?

sort by: active | newest | oldest
1-10 of 27Next »
I anticipated you might ask why reverse the diode .

You mixed analog logic with digital logic.

In the first pic is a 7414 with a led connected to the output of an Inverter only.

Truth table in 0 out 1

In the second pic I have in on the inverter connected to + and the out still connected to the LED.

Truth table in 1 out 0

However we are getting in 1 out 1 which is what your circuit is doing.

That is because 1 in logic circuits is -1 not +1

In the third pic I connected the in to the negative making -1.

Truth table in -1 out 0 which is what you want and get with this circuit.

In fact if I was building this circuit I would have built it like this.
002.JPG004.JPG005.JPGbackwards.bmp
So I should swap the source and drain of the JFET?
And should I reverse the diode or should I just take it out of the circuit?
Thanks for helping :)
Start one step at a time.

On the Jfet source to ground this is defiantly wrong.

If that don’t work pull the diode here the problem is the diode or the 1 mΩ resistor being too big.

Then if it still gives you trouble, pull the 12 + volts and 10 KΩ between the Jfet and the inverter and put a current limiting resistor about 1KΩ as in my pic.

Now if you still have trouble check the signal filter (the 1mΩ and the cap) it may need to be adjusted to bypass the oscillator signal.

From the picks + volts does not do anything for the inverter and no volts does nothing for the inverter. However – volts does make the inverter change state. Right now the inverter is getting no volts or + volts.
First your schematics are hard to read joints and jumps should be pronounced like this pic. Also on your jfet I cannot tell your source from your drain and whether it is connected correctly, now I could assume however that is a bad thing to do when trying to find out why a circuit doesn’t work. Also cannot tell the on or off position of your switches.
Testing 1a.gifTesting 1a.gif
That's not actually true, where wires cross over, the modern convention is there is NO join !
Have you read schematics on the net there is no standard there all over the place.
Professional work uses the convention, the net isn't authoritative.
It’s not just the net, many of the circuit simulator programs do the same thing, if you print the circuit you can’t tell a joint from wires that jump. As for the circuits on the net, you can tell the circuit simulator program they used to post the circuit by the picks. In my schematics there is no mistaking a joint from a jump even in a fuzzy pic.
There is no mistaking it drawn like this either

| |
__|___ __|___
| |
| |
Join No Join
Yes there is a very easy mistaking, I could not tell what you had there until I magnified the web page 400% to me it looks like the wires are touching.
1-10 of 27Next »