Instructables

Windows Media Player 11 Mini-Mode (Taskbar) Not Working

You know the thing that appears on your taskbar when you minimize Windows Media Player? With all the buttons (play stop volume etc.)? Well it won't go on the taskbar anymore, it just minimizes like a normal window. The options to enable it as a tool bar is gone too (right click in taskbar>Toolbars>Suppose to say Windows Media Player here).

I have a dream. A dream that in the future we will live in a world wide web in which information is shared freely and simply - without the need to sign up to a million bloody sites to write a paragraph.

I believe I may have solved the problem - that being no mini-mode in taskbar on a xp 32bit machine. (for 64 apparently it is not supported). As it turns out I solved another problem at the same time. My mspaint had disappeared from the computer and eventually I realized that it may have occurred when I removed some windows components through the add - remove programs window. I'd accidentally removed things I'd intended to keep because the process doesn't make it clear when it is removing or adding something. Anyway, popping in the xp cd and re-running this mspaint was back (so was my calculator among a few other things that I hadn't realized had gone, lol). I also noticed there is an option to remove media player and although I can't say for certain this is what had caused the problem because I'd already fixed mini-mode using Rinnaldo's fix (cheers mate - worked a charm), I am willing to bet that it was and this method would have sorted it out - Wuala (sic). Well, if it doesn't this post will at least help those out there whose mspaint has disappeared but keep getting unhelpful advice similar to djrico2006 below (thanks for the help). Although they probably won't find it in here, and signing up to one random web site tonite is enuf for me.
Rinnaldo5 years ago
I'm posting this because I've had the same problem and found a solution! I had no option for WMP when I right-clicked the taskbar->toolbar. This means the program needs to register a library file called "wmpband.dll". To do so, you simple can run a program called regsvr32 in the run prompt in the start menu. Tell it to run: regsvr32 C:\Program Files\Windows Media\Player\wmpband.dll If that doesn't work (and it DIDN'T WORK for me), simply copy the file (wmpband.dll) from the media player folder, and paste a copy directly in the C: folder. Then do the run command again: regsvr32 C:\wmpband.dll The second option worked for me (it will tell you if it was successful or if it failed). Then, restart Windows Media Player, right click the taskbar, go to toolbar, and the Windows Media Player should be back! Woohoo! Click it, and minimize the program to see if it worked. That's all. :)
thnx rinnaldo
Excellent!
@Rinnaldo, thank you SO much. I've been fighting with getting the mini Player in for weeks. Your second option worked perfectly and it was so easy! :D
Hey! I'm glad it worked for you! You're very welcome! :D
hey i tried both but doesn't work for me.. this problem exists since i opened a second user account in my xp sp2. and many programs also dont work properly in the second urer but works fine in the other user account. is there a remedy for this problem..??
 hi also i got same problem
my OS also has two users both are admins
in one the option works well but in other it's not working
did u got any solution for that
eddy91 Rinnaldo5 years ago
Rinnaldo, awesome man, thanks a buch!!
Rinnaldo eddy915 years ago
You're very welcome! :)
Whoops, that first run line should be: run: regsvr32 C:\Program Files\Windows Media Player\wmpband.dll Had an extra backslash in there by accident.
Aeshir (author)  Rinnaldo5 years ago
Poo pies, didn't work. Thanks anyway.
For Vista try running cmd as administrator it didnt work for me the first time but when i run it in administrator mode it worked
rsmamoru1 year ago
if the deskband option is missing, do this "before you register the .dll file":

http://msdn.microsoft.com/en-us/library/windows/desktop/cc144099(v=vs.85).aspx#band_registration

I quote this point:
---------------------------------------------------------------------------
Initially, Internet Explorer retrieves an enumeration of the registered Explorer Bar objects from the registry using the component categories. To increase performance, it then caches this enumeration, causing subsequently added Explorer Bars to be overlooked. To force Windows Internet Explorer to rebuild the cache and recognize a new Explorer Bar, delete the following registry keys during the registration of the new Explorer Bar:

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Discardable\PostSetup\Component Categories\{00021493-0000-0000-C000-000000000046}\Enum

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Discardable\PostSetup\Component Categories\{00021494-0000-0000-C000-000000000046}\Enum

Note  Because an Explorer Bar cache is created for each user, your setup application may need to enumerate all the user registry hives or add a per-user stub to run when the user first logs on.
---------------------------------------------------------------------------

then register the .dll file (i.e. regsvr32 wmpband.dll).
it works perfectly for me!
APS97 rsmamoru8 months ago
WHERE WILL I FIND THIS?------ HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Discardable\PostSetup\Component Categories\{00021493-0000-0000-C000-000000000046}\Enum
&
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Discardable\PostSetup\Component Categories\{00021494-0000-0000-C000-000000000046}\Enum ?????
rsmamoru APS977 months ago
Press Windows Logo + R, type regedit, press Enter.
lennon842 years ago
All the above didn't work for me (XP Pro SP3)

This worked for me instead:
1) Go to WMP folder
2) run wmsetsdk.exe
3) It will ask to validate Windows Genuine Advantage or something
4) Follow instructions
5) Go to task bar > WMP

Done.

Thanks for sharing.
Thanks,it worked for me!
5thFathom4 years ago
For Those that are still having trouble, here is an alternate way to do what Rinnaldo is suggesting. (For reasons I won't explain, it doesn't always work on some machines the way Rinnaldo suggests) 1. Close Windows Media Player 2. Open up a command prompt window (Start --> Run --> 'cmd') 3. Type in: cd "C:\Program Files\Windows Media Player" and it enter. 4. Now type: rgsvr32 wmpband.dll 5. If it succeeds, it will tell you! 6. Open Up Windows Media Player, and voila! Hope this helps.
Yeah Rinnaldo's suggestion wasn't working for me. This worked. Thanks for the input.
evermess3 years ago
Thanxs Rinnaldo!
GeHaD HaNy3 years ago
This article explains how
Minimize Windows Media Player to the taskbar
http://cairo-pro.blogspot.com/2010/09/minimize-windows-media-player-to.html
Lena Moe3 years ago
I have had same problem, but have now found the solution for all 64-bit windows. The problem is with the 64-bit version of explorer.exe, Mini player mode on the taskbar is not available. So you have to change to the 32-bit version. Normally, we have no use for the 64-bit version over the 32-bit version. In c:\windows you find the 64-bit version (1333kB) rename it (to explorer64bit.exe) The 32-bit version is found in c:\windows\sysWOW64\ COPY this file (1029 kB) to c:\windows Open task manager (from right click on the taskbar) In the Processes tab, click explorer.exe and click End Process. Then open the Applications tab, click New Task... and type explorer.exe Now the Windows Media Player Toolbar is again availiable :-)
Aeshir (author)  Lena Moe3 years ago
Hm, weird. I was on WinXP 32-bit at the time I posted this thread, but good job figuring that out. What a weird problem. :S
djrico20063 years ago
Easy fix guys instead of all the technical stuff of regedit and confusing issues that is irrelevant. You will laugh how simple it is in windows XP- Forget about your windows media player for a moment. Go to your task bar on your desktop and right click, then choose the following within the popup menu > Toolbars > windows media player (needs to have a tick) and wuala all done.
This problem is easy to fix in XP, but not in Vista or 7. Also, it's spelt 'voila', but using accented vowels.
Aeshir (author)  djrico20063 years ago
I already said in the original post that the menu item isn't there.

The options to enable it as a tool bar is gone too (right click in taskbar>Toolbars>Suppose to say Windows Media Player here ).
djrico20063 years ago
here is a screen shot
toolbar.JPG
Please don't post if you don't want to read the original question. Some of us would like to know the answer. Please stop playing around.
Aeshir (author)  djrico20063 years ago
I know how that menu works. I already explained in the comments that the menu item isn't there. Anyway, thanks for the help. :)
sfkask86 years ago
I signed up just for this so i hope this helps. About 3 minutes ago i was having the same problem . I started messing around and this worked for me. Right click the tool bar, go to tool bars then click on 'Links'. All the sudden WMP mini started working. I hope that helped.
NadaZ sfkask84 years ago
I tried each and everything from begining of this page.. nothing worked.. finally your solution did it..YAay..thanks sfkask8
brian804 years ago
Simply goto the toolbar...right click...select Toolbars...then click WMP. There should be a check mark in front of it. Hope this Helps!
Simple. Yeah, if you know how to do it.  Which I do.  I just totally forgot.  Thanks for the info.  Just what I was looking for.
squares6 years ago
I have a similar issue where the toolbar options are all available, but setting windows media player to "mini-mode" by right-clicking on the taskbar and selecting it's toolbar option has no effect. rantng your method will fail as the New Toolbar dialog does not allow the selection of applications as deskbands, only websites and folders. Un/reinstalling the windows media player taskbar interface with regsrv32 was a fruitless exercise. I suspect some corruption of wmpband.dll has occurred, but as I lack the time to properly investigate this machine's issue I'll instead reinstall the application and report my findings if unsuccessful.
rickick6 years ago
Did This work before , if so you can simply go into start menu , then go to programs, and go to accesories, go to system restore, your system simoultaneouly keeps like little backups of your settings and everything. Do this and then pick how far back you will like to go (Date (it will display a calendar))
rantng6 years ago
Right click the toolbar. Go to toolbar, new toolbar, find WMP on your computer. That should be it.
Aeshir (author)  rantng6 years ago
Naw I know about that, but the option isn't there anymore. It's weird. I said that in the original post xD
Pro

Get More Out of Instructables

Already have an Account?

close

PDF Downloads
As a Pro member, you will gain access to download any Instructable in the PDF format. You also have the ability to customize your PDF download.

Upgrade to Pro today!