Instructables

"image not available" in instructables; thumbnails won't enlarge


I can't see any of the main pics in any instructable, and the thumbnails won't enlarge. In many, I can't tell if it is something I want to do, or to save, because the images are  not there and the thumbnails are too small.

When I download it to my PDF files, the images are there, but at that point I  may decide this one is not for me. Then I have to delete it. Too much trouble just to see if an instructable is one that I want to keep, or even to mark it a favorite.

Thanks,
Jo

1-100 of 131Next »
mikeasaurus2 years ago
Instructable thumbnails / secondary images:

In order for all elements of the site to show up correctly on your browser all the background Java script needs to load entirely. If you are using an ad-blocker or any other type of add-on to your browser you may be stopping all the script from loading, thereby stopping the site from displaying content correctly.

We regularly test the site on basic, unaltered versions of popular browsers, and assuming no add-ons have been installed.

zany12 months ago

this is all the fault of instructables developer

Kiteman zany12 months ago

Er, you're chucking about insults based on a topic that is four years old.

The site has been though a lot of changes since then.

zany1 Kiteman2 months ago
i am experiencing this even now , i know the ppl at instructables are hard working but im just expressing my views , even with the latest chrome browser and with all plugins disabled it happens but does not happen on other browsers i cant just change my browser for one website.im sorry about the last comment i was furious about the pitures not loading at all so went on a quest to find the solution.
Kiteman zany12 months ago

Since you are the only person (currently) reporting this issue, I'd be inclined to suggest that the problem is at your end.

Have you cleared your cache and "hard reloaded" the page? Problems like you describe are usually down to the user's system holding on to code that predates an update rather than the site itself.

eh92 years ago
mikeasaurus wrote:
> In order for all elements of the site to show up correctly
> on your browser all the background Java script needs to
> load entirely.

This isn't a technical necessity. All that's necessary is to ensure that foreign scripts are present (i.e. that they actually loaded) before trying to run them. <code>if ( func ) { func( ... ) ; }</code>.

If you want to insist that you can't do this, at least be honest that it's a policy choice you all are making.
mikeasaurus eh92 years ago
If the policy you are talking about is waiting for the entire page to load and to ensure that no browser add-ons interfere with the loading of the page...then, yes.
LaserDave2 years ago
Hello all,

I have spent HOURS working on this problem - I'm using FireFox 10.0.1, AdBlock Plus, and NoScript. I fully understand and appreciate that I'bles tests their website using barebones browsers (without add-ons), but really...is this realistic since the majority of users are using them? It seems that NoScript is one of the most popular add-ons - so why not test it with it installed?

With an AdBlock-type add-on you will need to "allow" total clearance for I'bles - but NoScript has to be dealt with differently if you value your privacy. The "MAGIC" combination to make this icon-enlargement issue go away, is to "allow" instructables.com, googleadservices.com, facebook.net, and doubleclick.net - and being logged in or not makes no difference.

I have tried 7 different computers running similar versions of FF, so I know for sure what works and what doesn't. I'm particularly disturbed by the fact that Facebook (Failbook) must be allowed to run scripts when I don't want it to, nor do I want I'ble pages deluged with ads from google - but I suppose that the revenue gained by serving ads may be necessary to pay for server and bandwidth expenses to allow users to have free access.

*** I WOULD like to know what the deal is between Instructables and Facebook, and why we are forced to allow anything from that site to influence what happens on this one. I'm sure a lot of people would like to know why. ***

So, when you go to the I'bles site and want the thumbnails to open, go to your NoScript button and choose and permit the above mentioned services from the drop-down list. The page should reload with the new permissions, but it may be necessary to reload the page manually to make the thumbs open up. If this *still* fails to work, clear out your cookies and try again. A great way to do this without killing all your cookies, is (in FireFox) to go to Tools ->Options ->Privacy (tab) ->Remove individual cookie (link 2/3 down the page) - scroll down the list to "Instructables.com", click on that folder and choose "Remove Cookie". *** BE CAREFUL not to click "Remove all cookies" ***

This fix works well for FireFox, but the underlying script permissions issue may be fixed in the same manner with other browsers using the same method, but I have not been able to test any of them (I absolutely refuse to allow Internet Explorer to ever run on my computers)

One last point - since you may not want those services to have permission to run scripts globally, just "temporarily allow" them to run when you have I'bles up and running (through the NoScript list of items that want in). That way those services will be disallowed when you navigate away from the site, or you close that tab.

Hope this helps more of you that are pulling out your hair, I'd like to think that all my efforts with this might help at least a few more people to make it a little more worthwhile.

Just for laughs, post your results of whether or not this works for you, I'm curious to see how many users have been affected with this issue.

~LaserDave~
Thanks for the info Dave.

After reading your response I have decided just to download the PDF version of the instructables I need. I won't allow Doubleclick and the rest of the trash that instructables is forcing on us to get around NoScript/Adblock.

The PDF version has decent images.
jeff2 years ago
I'm in the same boat - thumbnails won't enlarge unless scripts from outside domains (googleadservices, facebook etc) are allowed.

This is not cool.
crosendahl2 years ago
Had the same problem in Chrome. Two different extentions were the culprits in keeping the thumbnails from enlarging: "Facebook Disconnect" and "Disconnect".

I looked through the source code on the page, and they are linking google analytics to each thumbnail via some javascript. I'm not sure why Facebook Disconnect is blocking it, though.

This is a fairly recent change, as it seems most of us have never seen this behavior before with various extensions installed. So, Instructables, is it really necessary for you to track which thumbnails are getting clicked at the expense of frustrating a lot of your users? I'm sure that very few of us actually bother to try an figure out why the site suddenly doesn't have a feature it used to have - there are probably a lot of people out there who just assume it's either broken or you took the thumbnail feature off the site. (BTW, I'm trying to be positive and constructive: I think you'd have happier users and don't have to sacrifice a lot of analytics to do it.)
The secondary images, along with everything else on a page is all tied to how the Java script loads up. The analytics track all kinds of stuff, and certainly not limited to secondary images. These analytics are important to how we direct our users interest in our site.

We can't determine which add-ons any given users' browser, so we design the site assuming no add-ons.
doxsys2 years ago
I've been experiencing this problem (in which clicking on the thumbnails under the main image does nothing) for quite some time. I'm using FireFox with NoScript and Ghostery, and had similar problems on Chrome with a NoScript-like extension installed. Is this going to be fixed any time soon? Much of the value in the pro membership is in being able to see everything blown up to full size.
NoScript is probably the culprit. We test and implement the site assuming no add-ons. Disable those and try again.
indomitable2 years ago
logged in now... thumbnails wont enlarge. i did clear the cache.
a.steidl2 years ago
Same problem here, even when logged in. I'll click on a thumbnail, nothing happens.
canucksgirl2 years ago
Bumping this topic to help members find this info (versus creating yet another redundant report). ;)
I'd love to see this problem fixed, as this issue is pretty debilitating to this site.
You might want to read through the comments below and try some of the "fixes" that have worked for other members. It might help until there is a permanent solution.
Philbert D2 years ago
Since posting about this to another location on 2 Mar 12, I found and read this thread.
Bottom line: it appears that both doubleclick.net and googleadservices.com must now be allowed in order to view the enlarged thumbnails.
Doubleclick.net, part of Google, generates a tracking cookie. There's nothing benign about this practise. I don't allow tracking cookies on the grounds that if a company wants to monitor my web surfing habits they can pay me for the information.
Googleadservices.com is simply adware which shouldn't be required to access anything on any site for any reason. Even Google itself doesn't require it.
I take the lack of a representative response from instructables.com as an indication of their adoption of the "let's flog the visitors info for fun and profit" approach. While I've found the articles very interesting, until this attitude is reversed, I won't be back. My habits are not instructables' to sell. This is as positive and constructive as I can be.
Instructables, why is the presence of these cookies required to allow the thumbnails to work?

....should read

Instructables, why is the presence of these cookies NOW required to allow the thumbnails to work?

...when for all the time I've used the site, it didn't need them.
I'm not sure that they do - I switched adblocker back on (set with no exceptions) last week, and I can see all the thumbnails.

(Using FireFox 10.0.2 under Windows XP)

I'm not using adblocker, I'm using NoScript. I can toggle adservices on and off, and see the functionality come and go at will (same platform)
All I can say is, with all the ad services blocked, the thumbnails work for me.

Looking at Lebowski's comment (Mar 12, 2012. 12:19 PM), maybe it's a Javascript issue?

We are in the process of rewriting our Javascript, so this should be fixed soon. We don't do any testing with ad blockers on, but we do not intentionally limit functionality for those that are using them. It's likely just stopping the imagespot javascript from running, which is what allows you to see secondary images.
Both doubleclick.net and googleadservices.com are used for the ads that are run on the site.
Well said Philbert.

I use Ghostery to block tracking cookies and have has the thumbnails problem.  I've just turned it off to allow the cookies and the thumbnails start working (displaying as the main picture).

Instructables, why is the presence of these cookies required to allow the thumbnails to work?
rbg0092 years ago
I am still having this problem. It started a week ago.
Running XP, and Chrome as I always have.
Unblock GoogleAdServices.
Ibles seems to have changed their code to mandate you using this script.
Steve
Thanks for your reply, but

How do I do that?
I'm afraid it means breaking some of the security your web browser is armoured with.

Are you using "Firefox" or Internet Explorer ?
No. As I indicated in my first post, I am using Chrome as I always have.
Kiteman rbg0092 years ago
Never mind - the adblock thing seems to have been solved (at least, I've switched adblosk back on, and I can still enlarge the thumbnails).
mgruwell2 years ago
ANNOYING!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

I cant see the small pictures, you can rest assured i will stay a free user now!!!!!
Unblock GoogleAdServices.
That's like uninstalling AV software if getting a virus warning... ;) Instructables.com has to exclude thumbnails from "Google Ad Section". It doesn't make sense at all to include those random file names...
Beats me. I agree with you entirely. I don't like enabling scripts to do key stuff either, but that's what makes it all work....

Steve
canucksgirl2 years ago
If you're having this problem, post your comments here instead of creating a new bug report. Its much easier for everyone if the problem and suggestions can be found on ONE page only. ;)
stjernegut2 years ago
The problem is in the google code on each page.
Find out if any of your plugins blocks any of googles functions.
Have been fighting this issue for a couple of weeks.

2 machines. Win7 pro and XP media center. both with Firefox 10.0.2 with AdblockPlus and NoScript.

I have tried clearing caches and temp files. Updating filters and disabling NoScript and AdBlockPlus with no happiness.

today, i retraced my steps through the processes on on both machines and disabling ABP and NoScript completely allowed me to view the secondary pictures.

Note that is is not simply disabling ABP and NoScript for instructables. Both must be completely disabled or FF must be started in "safe mode" with all addons disabled.

this is still an issue because enabling and disabling requires a restart of FF which is a pain in the ***.

Hope you get this fixed soon.

thanks.

tim
The answer seems to be that blocking "GoogleAdServices" stops you being able to view pictures in thumbnails. This probably to allow Instructables to maximise their advertising revenue or somesuch.
norumbegan2 years ago
I'm running into the same problem as a lot of people. I can see the main image for each step and the thumbnails below, but the thumbnails will not enlarge. Pretty frustrating. This happens whether or not I'm logged in, and whether I view all steps on one page or not.

Running Windows 7, Firefox 10.0.2. I disabled flashblock and adblock for instructables.com but that didn't help.
omnibot2 years ago
Same problem here since the last couple of weeks. I get the first image okay but nothing happens when I click the thumbnails.
Ubuntu 11.10, Firefox 10.0.1
DonQuai2 years ago
I am running Firefox 10.0.2 on Win 7 32bit (all updated) and I am unable to view thumbnails in full size. I click on them and nothing happens. I have disabled Adblock, cleared cache and cookies but still the problem persists.
Same here.

Firefox 10.0.2
Windows XP with newest updates

Fixed the problem for now bei deactivating firefox app "noscript".

Greetings
stjernegut2 years ago
I'm using Google Chrome v17.0.x on Mac OS X v10.7.3
But with Firefox v10.0 it works.
I'm still having this problem, thought it was just me.

Using Windows XP
and Firefox 10.0.2

Tried Clearing Cache and Cookies, etc, and just upgraded java and avast antivirus this morning, still no solution.
derkosak2 years ago
I'm seeing the same problem (Firefox 10.x on Windows 7 x64/OSX Lion, Safari on OSX Lion). But, on the same Windows machine, viewing the site with IE 9 works fine.
archerj (author)  derkosak2 years ago
I've found the same thing: I can get everything just fine on IE, but the problems are on Firefox. It's a lot of trouble, and I love Firefox, but I guess I just have to live with it for now.
klincecum2 years ago
Not working on firefox 10.0.2
Logged in in internet explorer, seems to work.
amateurasu2 years ago
Similar problem. I can see the first pic on each page, and the thumbnails, but clicking the thumbnails has absolutely no effect. Large picture doesn't change, no prompt to login, nothing. Firefox 10.0.2, Win7 64 bit. I have tried clearing my browser cache, and also making an account to log in under. No change from that either.
byayoi2 years ago
Hello. I have a similar problem. I can see the thumbnails, but the enlarged images just don't appear. It started happening about 2 weeks ago.

I'm using Win XP Service Pack 2 (in spanish), Firefox 3.6.18, logged in as non-pro.
jatoha2 years ago
I am also having this problem. On Chrome, not using Adblock.
Demonic692 years ago
This is happening to me now, though I'm pretty sure it's new. On Windows 7 with Chrome 16.0.912.75 m
I am having issues with thumbnail pics not enlarging. I too can dl the PDF and the pics are there. However, I can see the tiny thumbnail pics, but when I click on them, it does nothing. I have cleared my temp files and history and a bunch of other stuff and its still not working. Any idea on an easy fix?

PS, I am running Windows 7 with whatever the latest version of Firefox
AdBlock Plus was the issue. I disabled it for this website so it now loads pics and everything is now working correctly. I even have tags now.
Damn, I'm not running adblock plus. Must be a proxy issue
FazJaxton4 years ago
It looks like the fix has helped several people, but mine is still misbehaving. I see the image thumbnails, but clicking them does not display the larger image. I am logged in as a non-pro member. If I log out, clicking the images prompts me to log in to see them. I am running Firefox 3.6.9 under Ubuntu 10.4. Thanks!
Just tried again today with no changes, and it's working. Thanks!
CyborgGold4 years ago
Mine was fixed for a few days.. but it's broken again.

Windows Vista, Chrome / Firefox / IE8

Cache emptied on all browsers and temp files removed from Windows.

I made no changes whatsoever to my system between it working and not working (after you resolved the issue the first time)

Is it possible your server has been compromised? Virus or hacked?
jadawan4 years ago
I am still having this problem. Using Mac. Tested on Chrome, Firefox, and Safari. Cleared cash on all. Loged-in as free member but will not show extra pictures when thumbnail is clicked.

Thanks for all you guys do!
fbuth4 years ago
Secondary images won't enlarge. Using XP SP3, IE8. Logged in.
I have not been able to do this for YEARS.
I found a browser that worked last year (don't remember which one, prolly FF).
I have avoided I'bles since then because of this difficulty. Decided to give it another try today and found a brand new (ish - 2 weeks?) thread about the SAME PROBLEM.
Haven't tried others today because others say "no other browsers work".
Just cleared caches last nite.
jackhg4 years ago
me too, I can't the thumb nail pics to open up? help

and BTW, I made the paracord belts months ago from instructables, best belt I ever owned,

next i am gonna make a paracord purse, my lady friend said go for it, she also said it might be to heavy, I'll let you instrucables people know.


GO INSTRUCABLES!

my idea for instructables, maybe have more themes, e.g.,

like:
instructables legal,
instructables professional,
getting a degree from this site, I believe it can be done, a lot of people know a lot of stuff, we could do away with brick and mortor tenured professors, in some cases not all, if it is knowledge thats makes the degree, we could exchange the knowledge amonst each other towards a degree,

I could go on, the old paradigm is crumbling, instructables may will be the new method for "exchange teaching" my term, it is truly something to ponder,

To the owner and moderator of this site, I invite you to explore, to render the possibilty of exchange teaching, some aspects of the method of teaching, namely labs, probably cannot be done away with, but if we just sit at a computer to learn, the brick and mortor tenured model can be dispensed,

and yet again, go instructables, go to a new learning modality, that has already been proved to work, IMO, you have proved this exchange teaching to work

Jackingreen4 years ago
I also have the same problem. I use google chrome and XP!!!!
tsondie214 years ago
Hello,

Mine still doesn't work. This is the first time I have opened instructables at all on this computer and another computer (windows 7, windows xp). If I click the thumbnail, nothing happens. If I open it in a new window, it just takes me to the same page.
CyborgGold4 years ago
Wheeee all better now! Thanks!
archerj (author) 4 years ago
I cleared my recent hx, then Javascript told me that I do have the latest version, But I still can't see either primary or secondary pictures. Is there anything I can try now. How far back should I clear my hx?
Hisart4 years ago
Thank you!
It's working fine now, thanks again!
x-treme4 years ago
Now working in Chrome. :)
rocdenindy4 years ago
Thank you. Its fixed on my end atleast. I can now view the thumbnail pictures.
67spyder4 years ago
Just to add more detail, I am running Firefox 3.6.3 on Linux and noticed this problem earlier this week. I was looking at an instructable when the secondary images stopped coming up. The thumbnail is there but nothing happens when I click. I tried this on my work computer (identical software) the next day and had the same problem. If there are any more details I can add that will help squash this bug please let me know.
That's interesting! So two different machines showed the same behaviour. That helps to reduce the chance that it's simply a caching problem. Do you normally view I'bles at work? If so, did you choose one you'd previously seen, or a new one?
I always look at I'bles at work (I am self employed so the line between home and work is blurry) The problem happened with a new one and then any I'ble after that. The problem has gone away at the home office so has most likely gone away at my work office, I'll let you know.
Madrias3574 years ago
It works! Thanks!
boingx4 years ago

After reading the post saying that a fix had been implemented, I cleared my cookies, cache, history, etc... and logged off and back on. I did not close my browser.

I was able to see the secondary photos on both of the instructibles (new and old) that I mentioned in my previous comment.

I am using IE8.

Thanks guys and gals, for getting this fixed.

kelseymh boingx4 years ago
Yay! Thank you for testing this so quickly, and great that it worked for you. Hopefully some of the other users with problems will be able to do the same.
rocdenindy4 years ago
I posted this comment under FAQ and it got moved to bugs and was told to post it here. I have been unable to load the thumbnail pictures. I have tried it on Windows 7 and XP. I have tried on IE, Firefox and Safari. Nothing is working. Thank you for your time with this matter.
Could you clear your cache and try again? I'ble awesome coding goddess (see above) just rolled out what should be a fix. It'd be great if the users who have been affected could see whether things are better for them!
rachel4 years ago
Jo, and everyone, thanks for reporting this. I've just released a fix that should take care of the secondary image problem. Anyone who is logged in should always be able to see all the secondary images. Logged-out users can't, except for the most recently added Instructables.

Please give it a try now and let me know if you still have problems. The fix does make a change to some of the Javascript on the page, so you may need to clear your browser cache to make sure you get the new version.
thexmark4 years ago
Seems like this site is going to hell. In addition to not being able to enlarge thumbnails or view images, I also cannot post comments to ibles.

How long does it take to hire someone to fix this???
I presume you haven't bothered to read through any of the comments or discussion. The bug is not global -- many users, both paid and free, are not having any difficulties at all. Other users, both paid and free, are having only one problem or another, but not necessarily all. If you had any experience at all with management of large software projects, then you would understand the implications of a situation like this.
You presume wrong. I've read them all. Just because the problem isn't global doesn't mean it worthy of fixing, and fixing in a timely manner. The implications are huge for the company and its on-the-verge members; this I know. Hopefully you have the sense to appreciate the frustration.
The implication isn't that it is not worthy of fixing, but rather that it is extremely difficult to fix.

Suppose that when you are using your computer, one time in fifty it misbehaves (deletes a file or something). Suppose there's no correlation of the behaviour with the software you're using or the time of day. How long is it going to take you to isolate the source of the problem?
I'm just a pissed off, non-paying customer, so don't take anything I say here personally. I live in the internet and visit many many of the same sites multiple times daily and this is the first time in all my years that I've seen an issue go unfixed for more than a day or so. It really surprises me, that's all.
//doesn't mean its NOT worthy of fixing...
boingx4 years ago
When logged out I can access the secondary images on only some instructibles. I suspect I can see them on the new instructibles and not the old. Have not spent too much time on this.

Logged out I was able to see the secondary images on instructible:
http://www.instructables.com/id/Drink-Filter-Coffee-like-a-South-Indian/

Logged out I was not able to see the secondary images on instructible: http://www.instructables.com/id/Ghetto-Development-Environment/step3/The-Programming-Cradle/

No love when logged in on either instructible.




kelseymh boingx4 years ago
This is great detail; thanks! I've seen a variety of different issues when comparing "logged in" to "logged out" displays: for example, brand new I'bles sometimes show up sooner on the Recent page one way than the other, and counts of number of comments in the forum summaries can be different.

I *think* this is because I'bles actually has a farm of servers to help distribute the load when common pages are requested. It's possible that different servers are designated for logged in members, vs. anonymous access (e.g., so that Google's web-crawling doesn't impact member views).

When you ran your three/four tests above, did you delete your cache and cookies in between each one? One of the guesses which Matt has put out (and which we've seen with a lot of other of these display bugs) is that users are getting a cached version from their browser, which has content in it which is out-of-date relative to the server. This can sometimes screw up the JavaScript behind the scenes.

If you didn't try those "total cleanup" things, would you be willing to do so now?
x-treme4 years ago
Not working on Chrome on Windows Vista SP2. But it is working in Firefox.
what version of firefox are you using?
Firefox 3.6.10.
have you tried it while logged in?
I have tried it logged in and out.
Which thumbnails are you talking about, and were are you clicking to try to enlarge them? Could you reply with a sample instructable you're having a problem with, so I can follow along with your issues?
archerj (author)  StumpChunkman4 years ago
Example (but it's the same in every instructable that I look in):
"5 Vinegar Mysteries Solved"

"We will test 5 common vinegar theories and put them to the test."

After that there is a box where there should be a picture, and instead of a picture, it says "Image not found."

Step 1, Theory 1, Polishing Chrome. At the end of that step, there is another box that says "Image not found."

Step 2, Theory 2, Cutting Grease. Same thing--"Image not found."

With each step there should be a picture, but they all say "Image not found."

At the end of Step 5, under the "Image not found" box, there are two thumbnails. (Usually there are several of these thumbnails throughout an instructable, so maybe this one was not a good choice as an example.) But when you see one of these, you can click on it to enlarge it. In a lot of instructables these thumbnails are a great help in understanding the in-between steps. When I click on these, nothing happens--they do not enlarge.

Please let me know if this is not clear and I will try again.

Thanks,
archerj

Hmmm...Well that's interesting.  That's not a problem I think I've heard too much before, so it might be a little difficult (take a little while) to troubleshoot.  Let's start with a few questions:

What operating system and internet browser are you using?

Have you tried using different web browsers then the main one you normally use?

Has instructables worked for you properly in the past?  And if so, since the website broke for you, have you tried restarting your computer?
archerj (author)  StumpChunkman4 years ago
OS is Windows Vista. Mozilla Firefox is my browser. I have not tried IE because I don't like it. Instructables worked properly in the past. I have rebooted many times since this started a week or so ago. I spend a lot of time in Instructables, so I really miss its not playing nice for me. Hope you can figure it out.
"I have not tried IE because I don't like it. "

hehehehe. nice! lmao
I have the same problem. Do not have a solution. But you are not alone. Using Chrome and Vista.
mac os x 10.6.4
safari 5.0.1 & 5.0.2
firefox 3.6.9

it has worked before and does work if I login, then logout, the thumbs seem to work, however if i just login, the thumbs do not work.

Yes I had to restart to apply a safari and macos x update, from 5.0.1 to 5.0.2. Still same problem.

I might recommend it could be a problem with Non pro users possibly...
it is a problem for non pro, not with...

That is one thing that makes the problem more upsetting, because it seems (to me for a few thought cycles) a devious marketing ploy to make people pay for pro...the only thing is lots of folks made their instructables to freely share...so it's important to include free users, as much content would never have been if it weren't for free folk.
1-100 of 131Next »