Instructables

print pdf not working

http://www.instructables.com/id/Traditional-baguettes-by-hand/Traditional-baguettes-by-hand.pdf

returns no pdf and the error

0 PageResult values not set

Resin Professional 3.0.23 (built Mon, 22 Jan 2007 02:25:17 PST)

kirnex4 years ago
Anyone still having this problem? Each time I try to savePDFs via "Save Target As" it tries to save it as a zero-file HTML. If I click on the pdf link directly, it just refreshes the page. Grrrrr. Help?
I'll suggest you to download a imaging SDK ,which can create,load ,>save pdf easily.i've used one of the image SDK.That's good!
http://www.rasteredge.com/how-to/csharp-imaging/pdf-get-to-start/
Microbe (author)  marrisazhang7 months ago
4 years later...
kirnex Microbe7 months ago
Are you using Chrome? Google needs to get their sh!t together--so many of their services have failed for me recently--including Chrome. I was having this issue constantly using it. Apparently, there are issues with the new adobe flashplayer updates, etc. I finally got tired of it and uninstalled Chrome and am now using Firefox--which is much more reliable.

The other thing is: apparently, according to the site's twitter feed, at least one of the app servers are currently down. They recommend clearing all site cookies, then trying to load the page (or download the pdf) again. It definitely helped me--I was getting the "technical difficulties" page until I cleared my cookies, and it's been fine since.

Hope this helps.
strmrnnr4 years ago
Have downloaded and installed the latest version of Firefox and have upgraded to PRO and still can't download .pdf files. The link to the pdf opens a new window and copies the original link page it was made by. I try the links on this new page and the page reloads in the same window.
Problem solved. I had to add an Adobe Flashplayer plugin to the new Firefox browser. Seems to be working fine now.
ewilhelm4 years ago
Work for me. Try it again?
Still failing, Eric, as of Saturday 6 June. Pull up an I'ble, click on the "PDF" icon as the last step. You get a new page (eventually!) with a URL link like

http://www.instructables.com/pdf/Modified_Crib_for_Parent_with_Disability/Modified_Crib_for_Parent_with_Disability.pdf

Trying to access that link (as Microbe noted in the topic text) returns a new tab or window with the "Resin Professional" error report.
That PDF is downloading fine for me.
kirnex ewilhelm4 years ago
Out of curiosity: what browser (and ver.) are you using? I'm on a Vista machine that just updated recently, which I suspected caused some of the problems. I'd also recently upgraded to IE8, then downgraded out of frustration at how slow pages were loading. Now, this made me paranoid, so I went ahead and upgraded to IE8 again. I suspected it might be the adobe add-on for IE, but from what I've seen thus far IE8 doesn't allow you to update your add-ons as easily as prior versions. Knowing your (correctly working) browser and Acrobat type (reader, or full version), as well as the version might be helpful. Thanks in advance!
ewilhelm kirnex4 years ago
Latest version of Firefox.
Okay. I just tried now (see the time stamp on this message), and the PDFs (both mine, above, and the original posting) are being accessed correctly. Perhaps this was a side effect of the Flushing Of The Cache Servers? A more insidious bug might be that an un-cached PDF cannot be "triggered" by a non-Pro account, but once triggered (e.g., by Eric trying to repeat the bug) the cached version becomes available to all. It might be worth creating an internal account without Pro or Admin access, in order to do these sort of bug tests...
Favouritism on the part of the severs? ;-)
jd570a kelseymh4 years ago
I wonder if this has anything to do with the new Pro accounts?
kelseymh jd570a4 years ago
Not directly, I don't think so. The policy which Eric promulgated before the Pro accounts were launched was that all of us who were registered before the roll-out date would have "full" access (i.e., to everything we had before, but not to the new Pro-only stuff) for three months of transition.

Every time I'bles does a major software upgrade (remember when Answers first came out?) there are features which are temporarily broken. I am confident that this is one of them, but it seems to be repaired now.
jd570a kelseymh4 years ago
Looks like you were right. Working great now!!
strmrnnr4 years ago
Mine was working fine Sunday afternoon but has now started to lead me back to the original instructable pdf link page, (seperate window) rather than the pdf page in a seperate window as usual.
strmrnnr4 years ago
Like the new pdf download design, but it does not work. Any topic I have tried has shown download complete with a blanck page being the result. Also the system seems dead slow everywhere I go on site. Other sites seem to be normal, so It tells me it is here only. Thought I would let you know. Great site, by the way.
kirnex strmrnnr4 years ago
Ditto, and ditto!
kirnex kirnex4 years ago
For troubleshooting techies: My info: --Platform: Vista, updated --Browser: IE 8.0.6 --Acrobat: Reader 9.1.0 --Adobe reader add-on: Adobe PDF Link Helper ver. 9.1.0.163 --recently updated Norton 360 Version: 3.0.0.135 (was having problems, though, before then) If we all provide this kind of info, maybe we can figure out where the issue is ourselves.
Microbe (author)  kirnex4 years ago
it is not a problem at our end. It is the server not creating the PDF file properly.
strmrnnr kirnex4 years ago
Were you able to download after you upgraded to 'PRO'.
kirnex strmrnnr4 years ago
Nope, not on all pdfs. Some will, some won't. Tells me the site is having some problems, as I'm also getting error messages up the wazoo on most of the site's pages. I am assuming somewhere, somehow there is a tiny Instructables techie working their fingers raw to fix this issue. Maybe not, but I like the imagery, anyhow. If you're considering upgrading as a means to fix it, I'd say hold off. I did that, and...well, as you can see, it's not exactly the panacea I'd hoped for. :S
I'm confident instructables is on it. Patience! :-)
Yeppers. I don't wish for anyone to have been stuck in a computer room all weekend trying to fix code, so I'm sure we can all manage until it gets fixed. Demand is good, however. It would completely suck if you have a site with bugs and NO ONE notices. There's gotta be some satisfaction in knowing your site offers stuff that people want so much it totally frustrates them when they cannot get it.
Indeed, you're right.
Microbe (author) 4 years ago
Some people get it to work, others don't It is clearly a bug. Now I get Error 503 Service Unavailable Service Unavailable Guru Meditation: XID: 355498155 Varnish FWIW I am using XP Pro and FireFox 3.10 but have also tried it IE 8
I am getting the same problem at this site http://www.instructables.com/id/Ballistic-Gel/?download=pdf

Let me know when it is repaired OK?
I just tried to DL that PDF myself, and this time when I clicked "Save Target As" it tried to save it as an empty file HTML. I checked the error box at the bottom of IE8's status bar and got this:

"Webpage error details

User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.0; Trident/4.0; GTB6; Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1) ; .NET CLR 3.0.30618; OfficeLiveConnector.1.3; OfficeLivePatch.0.0)
Timestamp: Sun, 7 Jun 2009 23:11:38 UTC

Message: Object expected
Line: 290
Char: 3
Code: 0
URI: http://www.instructables.com/id/Ballistic-Gel/?download=pdf

Message: Object expected
Line: 294
Char: 3
Code: 0
URI: http://www.instructables.com/id/Ballistic-Gel/?download=pdf

Message: Object expected
Line: 299
Char: 3
Code: 0
URI: http://www.instructables.com/id/Ballistic-Gel/?download=pdf

Message: Object expected
Line: 417
Char: 4
Code: 0
URI: http://www.instructables.com/id/Ballistic-Gel/?download=pdf

Message: 'pageTracker' is null or not an object
Line: 737
Char: 7
Code: 0
URI: http://www.instructables.com/id/Ballistic-Gel/?download=pdf"

Anyone?

I have the same problem. I'm trying to back everything up, but it just gives me an error, no matter what option I try.
kirnex4 years ago
Same problem. I'm getting it on every single instructable while trying to access PDF downloads. Also, if I click on the "PDF" buttons to even try to ACCESS the pdf download links, it hangs a while, then loads, but then it goes to the "Internet Explorer cannot display this page....yadda yadda....navigation canceled" message box. WTF?
ihsancicek4 years ago
I have the same problem like jd570a, when I try to download a pdf, same things happen (even using different browsers like opera), I do not know what is causing this but it is absolutely annoying, I wont be able to archive my favorite instructables. If you find any cause or solution please let me know. Take care...
jd570a4 years ago
Same problem here. From the download PDF page, if I left click PDF to open or left click download custom PDF, I get : "0 PageResult values not set -- Resin Professional 3.0.23 (built Mon, 22 Jan 2007 02:25:17 PST)". If I right click PDF and and select select "save link as" the PDF downloads, but when I open it, it says "Adobe Reader could not open 'LED-Hardrive-Desk-Lamp.PDF' because it is either not a supported file type or because the file has been damaged (for example, it was sent as an email attachment and wasn't correctly decoded)." I have tried this on many many instructables this morning, always with the same results. Everything was working great yesterday. I'm going into Instructable withdrawal's. Thanks for any help
Pro

Get More Out of Instructables

Already have an Account?

close

PDF Downloads
As a Pro member, you will gain access to download any Instructable in the PDF format. You also have the ability to customize your PDF download.

Upgrade to Pro today!