private instructable - ERROR 400


Trying to publish a private instructable and receive:

ERROR 400: can not find item to publish: private

Project is formatted with multiple steps and pictures, nothing unusual. I have no problem publishing a regular instructable and everything seems normal while editing.
When finished editing, I can hit the tab for publish, or there's an tab option for private. I have attempted both methods: straight up publish has no options to make private, before, during or after going live. And, private returns the error message indicated above.

using:
Firefox 3.6.8
Windows 7

anyone else experience this?

Picture of private instructable - ERROR 400
sort by: active | newest | oldest

Hmmmm...I'm pretty sure that button is supposed to work.

I'll bring it up to the authorities!
NachoMahma7 years ago
.  You can't publish a private iBle. Try making it public and then publish. "If you would like to publish your Instructable to our community and have it included in our index, please make it public again."
mikeasaurus (author)  NachoMahma7 years ago
Not sure where you see: "If you would like to publish your Instructable to our community and have it included in our index, please make it public again". There's no options for me under 'private', just the error message.

When finished editing, I can hit the tab for publish, or there's an tab option for private. I have attempted both methods. Straight up publish has no options to make private, before, during or after going live. And, private returns the error message indicated above.

You must be able to post it as private, otherwise why would the tab be there? Or, is the easier option just to leave it as unpublished and share the url (ex: https://www.instructables.com/id/E4VHYDGFFGT/)


private.jpg
Hi, Mike. You might want to copy some of this text and the screenshot up into the main topic body. It'll help Matt and Rachel to have all the information together.
mikeasaurus (author)  kelseymh7 years ago
good call. updated
I just wanted to let you all know this should be fixed now. It works for me on my system, please let me know if you have anymore troubles with it.
mikeasaurus (author)  StumpChunkman7 years ago
Nice one, Matt. Just tried it and it works fine.
 
You rock, thanks!
.  I saw that when I tried to publish a private iBle of mine (clicked publish tab).
.
.  I get the same 400 error when I click private. I'm assuming that's a poorly implemented way of telling us that it is already private.
.
.  But I'm just guessing. Maybe one of Robot's minions will have an answer.
kelseymh7 years ago

Hi, Mike. I'm pretty sure this is a "recently" introduced bug. On my page of I'bles, it says:

"A private Instructable is a Pro-only feature. As a Pro member, you can make Instructables that are visible only to people you specify. A private Instructable doesn't show up on your member page, or in searches. You can show it to your friends by sending them the special secret URL. You can change the secret key in the URL at any time by editing the Instructable, then going to the Private tab."

Presumably, the private tab should generate a new "random" URL for your Instructable, but it's currently broken.