Introduction: Aicer A900 Wifi Audio Receiver Full Hack for Multiroom Streaming

Hello to everyone ! As I moved in my new flat I immediately decided to have some kind of audio streaming for the most significant rooms; I decided for a digital form of streaming because an ethernet cable was already in place and plain analog cable would have been not flexible enough in terms of input source and room selection.

My goal was to stream music from multiple devices (pc/android smartphone/smart tv) to one or more speakers connected to the wifi receivers in the most cost effective manner.

So I got those Aicer A900 as they supported not only DLNA which is not capable of handling multiple players but also Airplay also which actually is.

Problems as usual arises for those who tinkers with object outside their specified use, and as the vendor noted, the A900 are not supposed to be used more than one on the same network.

In fact they all have the same mac address ! so the router can't bind the correct ip to the right mac address and one of them was always not working.

Also I didn't like the fact that they also worked as wifi access point (I already have a router which i trust much more) and the names were too confusing and could not be renamed.

so:

  • Disable wifi
  • Change mac address
  • Rename receiver name

NEXT STEP !

Step 1:

Solution

First all I got some information from this excellent Instructable from engura with a very nice description of how put the receiver in recovery to be able to edit it's configuration and from open WRT forums to edit the files.

From his tutorial the first two pages for setup are required in mine too, so just reach the point with a ready telnet session to go back to this tutorial.

Problems (2)

Again my version of the A900 did not have vi, an unix based text editor to edit the configuration right on the A900, and the solution in the comments was not fully solving my requirements.


Solution (2)

As open Wrt have a possibility to push/pull files trough TFTP (trivial ftp) I managed to get all config files for editing, you will just need to download this opensource Sw tftpd32 and just run it.

The Current directory field indicates the folder files will be moved to/from (just to be carefull not to overwrite them !).

And now the fun part !

NEXT STEP !

Step 2:

Ok, from here some commands will be required, copy and paste are suggested as they will speed up thing a lot

1)First all let's get root ! copy this into putty (root command will make the config folders editable, just to simplify it)

mount_root

2)let's get to the configuration folder

cd /etc/config

3)let's take the files we need

tftp -g -r audio 192.168.1.2
tftp -g -r network 192.168.1.2

tftp -g -r shairport 192.168.1.2

tftp -g -r wireless 192.168.1.2

3)These files are all we need, now just edit them with notepad as you need, the part in bold italics is data you have to enter, the underlined just notes not to be copied.

All mac address must be the same among them !

AUDIO

config audioname 'audioname'

option dlnaname 'Insert here the receiver name'

option airportname 'Insert here the receiver name'

NETWORK

config interface 'loopback'

option ifname 'lo'

option proto 'static'

option ipaddr '127.0.0.1'

option netmask '255.0.0.0'

config interface 'wan'

option ifname 'eth1'

option proto 'static'

option ipaddr 'insert here the ip address you want the receiver to have'

option netmask '255.255.255.0'

option macaddr 'insert here the mac address you want it to have, you can just change a little the one present'

config interface 'lan'

option proto 'static'

option ipaddr 'insert here the ip address you want the receiver to have'

option netmask '255.255.255.0'

option macaddr 'insert here the mac address you want it to have, you can just change a little the one present'

config interface 'lan1'

option ifname 'eth2'

option proto 'static'

option ipaddr 'insert here the ip address you want the receiver to have'

option netmask '255.255.255.0'

option macaddr'insert here the mac address you want it to have, you can just change a little the one present'

config interface 'wifi_sta'

option proto 'dhcp'

SHAIRPORT

config shairport
option buffer '127'

option name 'Insert here the receiver name'

WIRELESS

config wifi-device 'radio0'
option type 'mac80211'

option channel 'auto'

option hwmode '11ng'

option path 'platform/ar933x_wmac'

option htmode 'HT20'

list ht_capab 'SHORT-GI-20'

list ht_capab 'SHORT-GI-40'

list ht_capab 'RX-STBC1'

list ht_capab 'DSSS_CCK-40'

option disabled '1' add this line if you want to disable the wifi on the receiver

config wifi-iface 'sta'

option ifname 'sta'

option mode 'sta'

option disabled '0'

config wifi-iface 'ap'

option ifname 'ap'

option device 'radio0'

option network 'lan'

option wmm '1'

option mode 'ap'

option key '4444'

option encryption 'psk-mixed'

option ssid 'B'

OK, NEXT STEP !

Step 3:

Most of it is done, now we just need to upload the files back and chmod them to give the right permissions to be executed.

tftp -p -l audio 192.168.1.2
tftp -p -l network 192.168.1.2

tftp -p -l shairport 192.168.1.2

tftp -p -l wireless 192.168.1.2

chmod 755 network
chmod 775 wireless

chmod 755 audio

chmod 644 shairport

Good ! now just reboot and you are ready to go.

reboot

If you mess up and want reset everything to start afresh (recreates all files)

firstboot

Finished ! just install the right software to stream the music as airfoil for pc or AirAudio for android...and happy streaming music to your place !

Comments

About This Instructable

616views

5favorites

License:

More by LucaG2:Aicer A900 wifi audio receiver full hack for multiroom streaming
Add instructable to: