Cheerson CX-20 3DR Radio for New Board

27,900

13

44

Posted in WorkshopElectric-vehicles

Introduction: Cheerson CX-20 3DR Radio for New Board

This Instructable is for the Cheerson CX-20 with a different APM board than most other people have. These steps will explain what I mean. There is very little instruction for setting up telemetry with this board, but I managed to figure out how to get it working properly.

Step 1: Telemetry Unit

This is the Telemetry unit that I am using. It is a 915Mhz model and it comes with the necessary components to install the telemetry.

Here is a link on amazon for this exact unit:

http://www.amazon.com/gp/product/B00Q7VC7AC/ref=oh_aui_detailpage_o03_s00?ie=UTF8&psc=1

Step 2: Opening Your Quad

The first thing you need to do is take the top part of your quad off. They supply the tools.

After that you need to locate the box that is in the middle of the craft and open it. There will be a zip tie around yours, you just need to cut it and you can put another one on when your finished if you wish. Once you open the little box there is a piece of foam. That needs to go back on there in a similar fashion it came off.

Step 3: Accessing the Port

After you open it up, take it out carefully and flip it so you can see the underside. There should be a port already soldered onto the board and labeled UART. If this is not there, this Instructables is not for you.

Find the cable that came in your telemetry box that fits the port and plug it in.

Step 4: Clipping Some Wires

On the end of the cable that plugs into the port on your APM board, clip the Green and Yellow wires. I would clip them pretty short, you won't be using them on that end of the cable. On the other end (The end that connects to the remote telemetry unit) Leave the wires long and strip the ends.

On the board the Ground and +5v are switched, so you will need to cut them and solder them to the opposite wire. So Red wire will now go the the black one, and the black one will go to the red one. Don't ask me why this is I have no clue.

Step 5: Soldering the Tx and Rx Wires

Take 2 extra wires and solder them to the location on the bottom of the first board. Wheres the first board you say. Well just like and arduino, the boards come apart. So carefully pull the boards apart and take the top board and flip it over. It should look like the picture. Those 2 extra wires need to be soldered to those 2 points on the board. These are Rx and Tx pins. Now it doesnt matter which wire goes where because if you mix them up the device simply won't work and you will have to switch them around.

Step 6: Connect the Rx and Tx

Now you need to solder those wires from the bottom of the board to the cable. You need to use the green and yellow cables that attach to your telemetry device, not the ones connected to the UART port that we clipped earlier.

In my case the White wire from the previous step goes to the green wire and the Black wire goes the yellow wire.

It may be different for you, so to check you need to go to your computer and see if both the ground telemetry (USB end) and the remote telemetry can connect. There should be a solid green light and a blinking red one. If the red one on the remote side is dim, the connections are wrong and you need to switch them.

Step 7: Finishing Up

Once you have identified the correct wiring, then your all set to put it some heat shrink tubing on for neatness and put it all back together. Your cheerson should now talk to mission planner

Share

Recommendations

  • Spotless Contest

    Spotless Contest
  • Microcontroller Contest

    Microcontroller Contest
  • Space Challenge

    Space Challenge
user

We have a be nice policy.
Please be positive and constructive.

Tips

Questions

44 Comments

After reading your instructable I switched all wires and came up with red(vcc),green(Tx),yellow(Rx), empty and black(gnd) connected to the UART.I get green steady light and red flashing on the 3dr,I can connect to droidplanner,I get the HUD working but I cannot arm the motors (indoors).Do I need to perform step 5 or is that natural?

2 replies

unfortunately this is normal for the moment. the problem is that the radios have different versions of firmware. I've tried to Google the fix and I have not come up with anything. if you find an answer let me know!

you have to get a FTDI Breakout board (about $3 on Amazon) and update the airmodule that way, it will give you the ability to connect the air side to your PC using a usb to mini or micro usb cable.. or use the 3dr radio configuration tool..google it

Does anyone have experience with wiring this this board with the minimosd and telemetry unit at the same time? I know some people have wired both to the UART port. I just have not found a clear tutorial as to how to do this. I have purchased a splitter that has the 5pin connector for the UART on one end and the 4pin to the telemetry and 6pin header female connector for the micro minimosd. I just want to make sure the wires are in the correct order for using both. This is the first tutorial I've seen with the new board that soldered the rx and tx. I'm hoping mine would work directly to the UART. Adding the osd to that wiring only increases my confusion. Any advice is appreciated!

1 reply

the 5 to 4 wire is designed for the APM FC, just make sure you have power, ground,TX and RX. on the APM you have to reverse TX an RX at the FC side I don't know about these

I have the same board version with a UART connector; it finally fell off when I kept taking out the connector since my Telemetry(ies) were not working correctly. I finally solder the wires to where the UART connector was but here is the thing, if I put in the 433mhz plug-I am able to pair and update the firmware via SIK radio setup (via Mission Planner), but NO heartbeat when I try to connect normally for flgiht programming. If I use my 915mhz plug, I only get a blue light and never sync with my 915mhz ground module. HELP!

1 reply

as long as you don't cross the power and ground, you can't hurt either board, so figure those out first the you can trial an error it.. GOOD LUCK!!

Thank you so much for this tutorial! I soldered the wires as instructed in step 5, and it works perfectly! Both on the computer and on the phone.

Hi, I have the quanum nova and have the new board also. I've been trying to install the radio for a couple of weeks now and have tried every bit of advice that I've found on multiple forums (mainly switching the wires around in the plug) But have had no luck. I was advised to upload a custom firmware (3.2.1) by nice chap on another forum, which I have but still no joy. I was about to give up until I came across this page and will try soldering the 2 wires soon.

I'm a bit concerned that the custom firmware that I've uploaded was write for the cheerson and wondering if it will still activate the telemetry on the quanum?

Also when I was first playing around by plugging the Uart cable in I noticed that there was a single dull red led flash on the air radio but now Im not getting anything, I haven't broke it have I?

Thanks for any advise

3 replies

lanW17

We have the same board 3.2.1 and it gives me headache at first but upon trying had it all working.

The picture is right but a bit confusing looking at it. what i did was

1. when facing UART, the last right hole of that is the black wire and opposite of that on left in the ground.

2.Cut the green or blue and yellow wire (dont need it in the UART

3. the Green/Blue and Yellow wire solder it on the TX and RX as indicated on the picture number 5. if it doesn't work try to interchange it and it will 100% work

I don't think the firmware will be a problem. The Uart cable is a little bi fishy. If your getting a dull red light that means your Rx and Tx cables are switched. if your getting no light, check your connections and also your positive and negative cables. It is not possible to short the board with the Rx and Tx cables, however it is possible to short the board if your positive and negative are wrong.

Thanks Aphire. I soldered the 2 wires last night and still got nothing so I guess I've shorted the board some where down the line. If you are looking a the UART board flat on with the UART socket at the top, what side should the black (ground) be?

Hi all, I've finally got my telemetry working thanks to Aphire. Turned out to be a faulty transmitter. Now it's all up and running I've noticed that it's disabled my SWA & SWB-0 switches. Is this normal?

@Aphire, which telemetry unit should I use then? Any possibility to use it with Bluetooth?
@js349, any chance you good do a video, I'd love to see how it works on screen. Thanks.

Could somebody please help me? I have the exact same APM board with the UART connector so I've followed your instructions and I get a green light blinking on both of the telemetry units and when I click connect on my tablet (what I'm using for a computer) in the Tower (Droid Planner) software, the red light blinks on the telemetry unit that is connected to my tablet but the green light continues to blink on the telemetry unit connected to the UART and no other light comes on. Any ideas what I may have done wrong?

4 replies

The telemetry unit that is featured in this Instructable is not tablet compatabile

Thanks for answering Aphire but I'm really confused about that. I had seen this https://github.com/DroidPlanner/Tower/wiki/How-to-connect and thought that was what you could do with this. I thought this was great because you could carry a small tablet out in the field and plot your course there. My Android tablet recognizes the USB module and the module has a green light that comes on and when I click connect, the red light blinks but it doesn't connect with the module plugged in to the UART and the UART module has a green blinking light. I'm using the Android app named Tower (previously named Droid Planner). So when you use a computer, what application do you use? This is what really confuses me because with the open source version of this quad (which is what I have), you can already connect it to a PC and plot a course there with that version of Mission Planner. Is this just for non open source CX-20s?

Yes the tablet may recognize the usb module, but this is mean't for a laptop. The board on the CX-20 I believe does not support any other program besides Mission planner.

OK, well that's disappointing. Now, I've downloaded and installed Mission Planner v1.3.25 to my laptop and started the application and I have my USB module plugged in and the module plugged in on the quad and connected a battery and both units have green blinking lights. When I click connect nothing happens and it just times out. Do I have the wrong version of Mission Planner or did I miss something? Thanks again!