Introduction: Stop Skipping Audio in Google Music & YouTube

Does the sound skip or become "choppy" when you are watching YouTube videos or listen to music with Google Music in Chrome, and do other things on your computer? I have a pretty slow work computer, and was frustrated that I couldn't listen to my streaming music and work in Auto Cad, or any other programs without terrible skipping.

While playing around, I discovered that by disabling the PPAPI Flash plugin fixed this issue and had no effect to my Flash performance (except vast improvement). I'm not sure if this issue occurs in other browsers, but disabling this may help with them too.

Step 1: Go to Chrome Plugin Settings

In the address bar type "chrome://plugins" without quotes.

Click on the "+" beside Details, this will show all components of each plugin.

Step 2: Disable PPAPI

Locate "Type: PPAPI (out-of-process)" under the Adobe Flash Player plugin. Click the Disable link. This will change it to look like the photo here. 

Close your browser, and re open it.

Now try your streaming audio! With any luck, you are back pounding the beats without the choppy annoyance.

Comments

author
JimS273 made it!(author)2016-10-03

This didn't work for me, so I looked around and found a fix.

In a new tab, open chrome://settings/
Scroll down and click to "show advanced settings"
Scroll down to "System" and check "Use hardware acceleration when available"
Restart Chrome.

author
JockoP made it!(author)2015-10-11

Can't believe it, tried all sorts of other solutions and Voila! Worked instantly! Was one of those nagging things for months not worth spending real time on until I just said screw it and put the effort in to look this up. Thanks so much!

author
clweeks made it!(author)2015-09-11

Thanks! That's been bugging me for a week and your solutions was perfect.

author
JohnB57 made it!(author)2015-04-08

Good tip!

author
R.+Shing-LaiH made it!(author)2015-04-03

Worked like a charm! Many thanks.

author
NataliaL1 made it!(author)2015-03-30

Thanks for posting this! It solved my issue right away!

author
GabyE1 made it!(author)2015-01-23

It worked!

You just made my day THANK YOU! I've been trying to fix this for MONTHS!

author
ricky.vanderdonckt made it!(author)2015-01-05

This totally fixed it, straight to point, no bullshit, people like you make this world a better place

author
ralph.mizia.1 made it!(author)2015-01-03

I tried those fixes with no luck. On a whim I downloaded firefox(not as my default browser). I went to you tube and voila.... perfect audio. Enjoy.

author
jn115801 made it!(author)2014-12-06

worked for me, thank you!

author
michael.gordon.336 made it!(author)2014-12-05

Tried this, still no luck. Tried disabling both versions and following the links to reinstall flash and I get through the installation process and it still tells me I need to install flash. Chrome needs to completely remove their integrated version ASAP or seriously find a fix for this. I'm tired of my CPU being maxed out and lagging when I try to stream a video. I've tried multiple options and I can't seem to get it corrected.

author
LegoPig made it!(author)2014-11-22

Does nothing unfortunately

author
cawthon2 made it!(author)2014-11-17

Better, still not fixed though.

author
annabella.kizzle made it!(author)2014-11-10

It worked! THANK YOU!!!

author
TrishaRigginsGraham made it!(author)2014-09-15

Did the disable on the Chrome Pepper Flash (Out-of-process) months ago. Still have same problem with audio. :-( Helped on a couple of other problems though. :-)

author
ronaldu made it!(author)2014-09-04

i friggin love you man it worked been looking for a fix about 6 weekx yayyyyyyyyyyyyyyyy

author
damon.hendrickson.77 made it!(author)2014-08-20

Hey thanks, I have had stuttering problem off and on.
Totally gone now.
win7 64bit
chrome - Version 36.0.1985.143 m
PS, NPAPI plugin will auto enable after every chrome update.