Introduction: Xcode 6.3 on OSX 10.9.5 (swift 1.2, Ios 8.3, ...)

Hello everyone
If like me you hate yosemite or if your mac is not sufficiently powerful and you program in swift, you are normally stay under 10.9.5 to use Xcode 6.2. But recently ios 8.3 and swift 1.2 are released, finally forcing us to passing under Yosemite. But with the XcodePostFacto framework by Landon Fuller (https://github.com/landonf/XcodePostFacto) we can stay under Maveriks ! To make the modification more easy (to use) I create a little app launcher. Here's how to install it.

Step 1: Install the App Launcher

First, you must be under 10.9.5. ^^

Next you need to download this zip here and drag the Xcode6.3 app on your desktop or in your Application folder or anywhere.

Step 2: Download and Install Xcode 6.3

You can't download the last Xcode from the app store, you need to download the dmg from the apple dev center here ( requires AppleId ).

Mount it and after drag it on your Application folder.

Note : I recommend you rename your current Xcode like Xcode6.2 in case of error or other ;)

Step 3: Launch Xcode6.3

After that launch the Xcode6.3 app on your desktop.
If you have an alert, right click on it and click 'open' (need make it only the first time).

And when you see " Unexpeted code bundle 'XcodePostFacto.ideplugin' " click on 'Load Bundle' and install it

You have done !

Step 4: Finished !

You are now in Xcode 6.3 and you can now program on ios 8.3/swift 1.2 :D

And Sorry For My Bad English ^^

Info : if you want rename the Xcode in Application folder, change the name in Xcode6.3.app/Contents/MacOS/Xcode6.3.command :
/Applications/Xcode.app/Contents/MacOS/Xcode by /Applications/"NewName".app/Contents/MacOS/Xcode

Comments

author
ManuM26 (author)2016-02-05

Hi,

i did all steps and xcode 6.3 starts, but if i wanna create a new project it will crash.

Pls help me.

author
ClaudioR14 (author)2016-01-14

Hey, so I can't find any download source for Xcode 6.3 or anything below 7, really. I clicked onto the Apple Dev site and couldn't find anything either. Next time I clicked the link provided in Step 2 it started downloading Xcode, but turned out to be 7 and not 6.3. Any help?

author
BrianE27 (author)2015-12-06

Hmm, i made it to the step where i should get the step (3,3):

>And when you see " Unexpeted code bundle 'XcodePostFacto.ideplugin' " click on 'Load Bundle' and install it.<

This doesnt happen to me. I have tried to restart, re-install and whatever. Im not prompted this message, and nothings happens when i try to launch the Xcode 6.3.app


HELP ME OUT HERE

author

Hi BrianE27.

I faced out with similar trouble. I have found the first version xcode 6.3 (6D570). May be this is beta version. With this version works fine.

author
tomatoskins (author)2015-06-24

Looks great! Thanks for sharing and welcome to the community!

About This Instructable

32,695views

13favorites

License:

More by gara12:Xcode 6.3 on OSX 10.9.5 (swift 1.2, ios 8.3, ...)
Add instructable to: