loading
1 Comments

Tell us about yourself!

Complete Your Profile
  • Rideable Segway Clone - Low Cost and Easy Build

    So I finished building my segway yesterday, however I have two issues:The first is that the arduino is not receiving enough power from the motor controller. I ended up grabbing a 9V battery connector for the arduino, however I didn't know if something was up with the controller or not.The second problem is that it's not working. I did download the code, and I have no compilation errors. I've tried using the turning switch, adjusting what it thinks is level, and even just taking the gyro and moving it around to see if anything would work (I was holding the deadman switch for all of these tests). The motors appear to be working, however when the gyro is tilted the segway doesn't want to move forward at all. The motors appear to be moving randomly when I use the deadman switch, however I c...see more »So I finished building my segway yesterday, however I have two issues:The first is that the arduino is not receiving enough power from the motor controller. I ended up grabbing a 9V battery connector for the arduino, however I didn't know if something was up with the controller or not.The second problem is that it's not working. I did download the code, and I have no compilation errors. I've tried using the turning switch, adjusting what it thinks is level, and even just taking the gyro and moving it around to see if anything would work (I was holding the deadman switch for all of these tests). The motors appear to be working, however when the gyro is tilted the segway doesn't want to move forward at all. The motors appear to be moving randomly when I use the deadman switch, however I can't figure out what's causing them to run. I downloaded the code straight from here and uploaded it to the arduino. All ports are the same as the above wiring diagram. Am I doing something wrong?

    View Instructable »