loading
9 Comments

Tell us about yourself!

Complete Your Profile
  • chadcm380 commented on diy_bloke's instructable Arduino controlled light dimmer7 months ago
    Arduino controlled light dimmer

    I removed the whole for() statement, so there is nothing in the void loop(), and it is dimming as before (see first screenshot).I have tried manually setting dimming = 0 and delay(10), but I am still getting a quick fading cycle. I thought that setting dimming = 0 would leave the triac on for the whole wave cycle, giving me full brightness, but it is still going through a dimming cycle (see second screenshot).Can you think of anything that would cause this?

    View Instructable »
  • chadcm380 commented on diy_bloke's instructable Arduino controlled light dimmer7 months ago
    Arduino controlled light dimmer

    I changed the 30k resistors to 15k, and have included a picture of the scope reading which shows some of the values you asked for. The width of the 120Hz signal is 8.310mS, Vpk-pk is 5.12v, Vrms is 1.47v. Still getting inconsistent dimming with basic dimming program.One thing I tried was removing the for() statement in the void loop() of the basic dimming program, and after I did that it started dimming consistently. I will attach a video. With the value "dimming" not changing, I was expecting a fixed brightness level, but instead it started running through the dimming cycle.Thanks for all your help!

    I changed the 30k resistors to 15k, and have included a picture of the scope reading which shows some of the values you asked for. The width of the 120Hz signal is 8.310mS, Vpk-pk is 5.12v, Vrms is 1.47v. Still getting inconsistent dimming with basic dimming program.One thing I tried was removing the for() statement in the void loop() of the basic dimming program, and after I did that it started dimming consistently. I will attach a video. With the value "dimming" not changing, I was expecting a fixed brightness level, but instead it started running through the dimming cycle.Thanks for all your help!

    View Instructable »
  • chadcm380 commented on diy_bloke's instructable Arduino controlled light dimmer8 months ago
    Arduino controlled light dimmer

    I wrote LOW to output, light stayed off.I wrote HIGH to output, light stayed on, no flickering.Disconnected arduino, light stayed off.

    I wrote LOW to output, light stayed off.I wrote HIGH to output, light stayed on, no flickering.Disconnected arduino, light stayed off.So it looks like the triac is working as expected. I wonder if it's an issue with the timing on the interrupt. I have the 60Hz signal coming from the mains passing through the 400v bridge rectifier, which produces a 120Hz signal. This is passed to the 4n25, then to the interrupt pin. I changed the values in the program from 75 to 65, and from 10 to 8.33 as instructed. Oscilloscope showed a pretty clean 120Hz signal going to interrupt pin.

    So it looks like the triac is working as expected. I wonder if it's an issue with the timing on the interrupt. I have the 60Hz signal coming from the mains passing through the 400v bridge rectifier, which produces a 120Hz signal. This is passed to the 4n25, then to the interrupt pin. I changed the values in the program from 75 to 65, and from 10 to 8.33 as instructed. Oscilloscope showed a pretty clean 120Hz signal going to interrupt pin.

    View Instructable »
  • chadcm380 commented on diy_bloke's instructable Arduino controlled light dimmer8 months ago
    Arduino controlled light dimmer

    I constructed the circuit, and the triac seems to be firing correctly. My light won't dim correctly thought. I put the basic dimming program you provided in step 4 on the arduino, but the light flickers rather than dimming. I'm guessing it is a timing issue. I am on a 120v 60Hz grid, and have changed the values in the program accordingly. Any suggestions?

    I constructed the circuit, and the triac seems to be firing correctly. My light won't dim correctly thought. I put the basic dimming program you provided in step 4 on the arduino, but the light flickers rather than dimming. I'm guessing it is a timing issue. I am on a 120v 60Hz grid, and have changed the values in the program accordingly. Any suggestions?

    I constructed the circuit, and the triac seems to be firing correctly. My light won't dim correctly thought. I put the basic dimming program you provided in step 4 on the arduino, but the light flickers rather than dimming. I'm guessing it is a timing issue. I am on a 120v 60Hz grid, and have changed the values in the program accordingly. Any suggestions?

    View Instructable »