author
4Instructables42,892Views36CommentsJoined October 18th, 2012

Tell us about yourself!

Complete Your Profile

Achievements

10K+ Views Earned a bronze medal
  • lkndave commented on deba168's instructable ESP8266 Weather Widget4 months ago
    ESP8266 Weather Widget

    Proof it is easy to overlook the obvious. you are 100 percent correct. i changed city to NC and it is perfect. this happens sometimes because i am 50 years a hardware guy and 5 years an arduino guy. i just kept propagating the error like a zombie. thank you for pointing out my error.again thanks, the next pint is on me.dave

    View Instructable »
  • lkndave commented on deba168's instructable ESP8266 Weather Widget4 months ago
    ESP8266 Weather Widget

    ok i had a few on last post. what i was trying to say is no change. compile loads and same. i up graded to ide 1.8.1 and same. no data. my api number is good. the time data from NIST is perfect so i am on the net.my serial mon info:.16:27:0416:27:459224Requesting URL: /api/4251c2bfd51169f3/conditions/q/US/Charlotte.jsonstart documentRequesting URL: /api/4251c2bfd51169f3/forecast10day/q/US/Charlotte.jsonstart document

    View Instructable »
  • lkndave commented on deba168's instructable ESP8266 Weather Widget4 months ago
    ESP8266 Weather Widget

    thank you for replies.the library seems to be fine. display works fine.the 4 frames are:1 correct updating time, no date, the left page dot is larger2 N/A with C and degree symbol. 2nd page dot larger.3 "humidity, pressure, precipit. and inside" displayed. no numbers or other data just the 4 wordsframe 4, 3 evenly space "NA: with a / below.. no sybols, numbers, 4th dot large.sequence repeats..the serial monitor never displays any data just a few numbers then something, "start document, then something else, "start document, then nothing more. no data no nothing.thats it.i did comment out the 2 libraries for the sensor and lines 71-88. i think i may have messed up the buffers by doing that.i added them back but am getting bitmask errors from the onewire lib. more ...

    see more »

    thank you for replies.the library seems to be fine. display works fine.the 4 frames are:1 correct updating time, no date, the left page dot is larger2 N/A with C and degree symbol. 2nd page dot larger.3 "humidity, pressure, precipit. and inside" displayed. no numbers or other data just the 4 wordsframe 4, 3 evenly space "NA: with a / below.. no sybols, numbers, 4th dot large.sequence repeats..the serial monitor never displays any data just a few numbers then something, "start document, then something else, "start document, then nothing more. no data no nothing.thats it.i did comment out the 2 libraries for the sensor and lines 71-88. i think i may have messed up the buffers by doing that.i added them back but am getting bitmask errors from the onewire lib. more if i find something, dave

    located correct onewire lib for esp8266. they removed it from the esp bundled core. now i compile with no errors, your original code, still no data. grrrrri got blisters on my brain cellsd

    View Instructable »
  • lkndave commented on deba168's instructable ESP8266 Weather Widget4 months ago
    ESP8266 Weather Widget

    after 8 days i am out of ideas. i gave up on debas code 4 days ago. loaded your code compiles great uploads and runs no errors. time displays perfect. no other data but the frames are there, n/a where data is supposed to be. i know my api, state and city work because it works fine from browser inquiry. i am not using temp sensor yet. the serial monitor says starting document twice. conditions and forecast. i login to wunderground and analytics shows i am hitting it without error. ideas?

    View Instructable »