loading
9Comments

Tell us about yourself!

Complete Your Profile
  • mjd1290 commented on Laurens-Wuyts's instructable Control Raspberry pi GPIO using an app6 months ago
    Control Raspberry pi GPIO using an app

    Awesome tutorial! Got this working in under an hour. Have lots of ideas planned now.

    View Instructable »
  • mjd1290 commented on Laurens-Wuyts's instructable Raspberry Pi Android App communication6 months ago
    Raspberry Pi Android App communication

    I really appreciate your responses and all insight!I managed to get this working! Something must've been incorrect in my .php files. I originally wrote the files myself, as writing the code helps me understand what it's actually doing. However, writing code in a nano editor almost seems like a fool's errand, as it is not an IDE and won't yell at you when you've done something stupid (haha).I copied & pasted your .php files, restarted the server, and voila!! My app's no longer crashing and instead indicates success, and when I verify in phpMyAdmin, sure enough there's the part!Thanks again for all of your help, and for making this instructables! It was incredibly informative, I learned a lot, and had fun troubleshooting my issues. Moving on to your instructables regarding control of ...see more »I really appreciate your responses and all insight!I managed to get this working! Something must've been incorrect in my .php files. I originally wrote the files myself, as writing the code helps me understand what it's actually doing. However, writing code in a nano editor almost seems like a fool's errand, as it is not an IDE and won't yell at you when you've done something stupid (haha).I copied & pasted your .php files, restarted the server, and voila!! My app's no longer crashing and instead indicates success, and when I verify in phpMyAdmin, sure enough there's the part!Thanks again for all of your help, and for making this instructables! It was incredibly informative, I learned a lot, and had fun troubleshooting my issues. Moving on to your instructables regarding control of the GPIO bus from my Android!A+

    I made sure to set DocumentRoot to /var/www in /etc/apache2/sites-available/000-default.conf (DocumentRoot was /var/www/html by default), and this is what I get when I point my browser directly to the IP:

    I also replaced the index.html file within the html directory (inside /var/www/) with an index.php file simply display phpinfo(); [ <?php phpinfo(); ?> ], which works as expected.. it displays the all relevant info regarding my server, php version, etc.maybe I should just copy & paste your php files.. and see if that makes any difference. I originally typed it out entirely, as it helps me understand what's happening in the code.

    I really appreciate your responses and all insight!I managed to get this working! Something must've been incorrect in my .php files. I originally wrote the files myself, as writing the code helps me understand what it's actually doing. However, writing code in a nano editor almost seems like a fool's errand, as it is not an IDE and won't yell at you when you've done something stupid (haha). I copied & pasted your .php files, restarted the server, and voila!! My app's no longer crashing and instead indicates success, and when I verify in phpMyAdmin, sure enough there's the part!Thanks again for all of your help, and for making this instructables! It was incredibly informative, I learned a lot, and had fun troubleshooting my issues. Moving on to your instructables regarding control of...see more »I really appreciate your responses and all insight!I managed to get this working! Something must've been incorrect in my .php files. I originally wrote the files myself, as writing the code helps me understand what it's actually doing. However, writing code in a nano editor almost seems like a fool's errand, as it is not an IDE and won't yell at you when you've done something stupid (haha). I copied & pasted your .php files, restarted the server, and voila!! My app's no longer crashing and instead indicates success, and when I verify in phpMyAdmin, sure enough there's the part!Thanks again for all of your help, and for making this instructables! It was incredibly informative, I learned a lot, and had fun troubleshooting my issues. Moving on to your instructables regarding control of the GPIO bus from my Android!A+

    View Instructable »
  • mjd1290 commented on Laurens-Wuyts's instructable Raspberry Pi Android App communication6 months ago
    Raspberry Pi Android App communication

    So I at least figured out part of my problem:in each of my .php files, the beginning tag was <? php (white space included) vs. <?php (white space not included). This put me one step forward, only now I'm not receiving any content at all from the server. In JSONParser.makeHttpRequest(), in the ("POST") part of the if statement:HttpEntity httpEntity = httpResponse.getEntity(); is = httpEntity.getContent();the InputStream object (is) is receiving zero content. So when I reach the code where the StringBuilder is built, my 'json' String object winds up being empty.Any ideas on why I wouldn't be receiving any content? Apologies for the 21 questions. This is just a very interesting tutorial and I'd love to get it working. I feel...see more »So I at least figured out part of my problem:in each of my .php files, the beginning tag was <? php (white space included) vs. <?php (white space not included). This put me one step forward, only now I'm not receiving any content at all from the server. In JSONParser.makeHttpRequest(), in the ("POST") part of the if statement:HttpEntity httpEntity = httpResponse.getEntity(); is = httpEntity.getContent();the InputStream object (is) is receiving zero content. So when I reach the code where the StringBuilder is built, my 'json' String object winds up being empty.Any ideas on why I wouldn't be receiving any content? Apologies for the 21 questions. This is just a very interesting tutorial and I'd love to get it working. I feel like I'm really close.

    If that were the case, wouldn't I have issues running phpMyAdmin? I can use the phpMyAdmin UI with no problems at all.

    (please, correct me if I'm wrong)

    Greetings Laurens,I've completed the steps in this 'instructables', and I'm going through the troubleshooting phase at this point. I seem to be able to communicate with my Raspberry PI, which is good. The problem I'm having is every time I hit the following call in JSONParser:HttpResponse httpResponse = httpClient.execute(httpPost);it returns the entire .php file, as opposed to an encoded JSON object of the $response array. I'm looking into this further, however I'm just wondering if you could provide any insight.Thanks in advance!

    View Instructable »