157Views15Replies

Author Options:

'73 Harley- Electrical Emergency! Answered

Ok, biker boys (and girls), I need help. After sitting all winter, I fired up my '73 Shovelhead. I had a battery charger attached (charging 12v @ 6 amps). The bike fired up on the fourth or fifth kick (YAY!!!), but then promptly fried the headlight, the taillight, and caught the charger on fire (in the carport). What do you think is wrong? Defective regulator? Poor regulator ground? I want to ride this weekend, so help me ASAP!!!!?

15 Replies

user
lemonieBest Answer (author)2009-04-13

Ooer! The charger was connected when you kicked-it over? Does your bike run or are the electrics 'toasted'? (don't know) L

Select as Best AnswerUndo Best Answer

user
skunkbait (author)lemonie2009-04-14

Yeah, the charger was on when the bike fired up. That's not the best thing, but I've done it before with no ill effects. The bike still runs, but I'm afraid to start it until I know what's going on. I'm afraid if there's too much juice it will cook the ignition.

Select as Best AnswerUndo Best Answer

user
lemonie (author)skunkbait2009-04-14

Without the charger, I wouldn't imagine you could cook the bike anymore. I'd be inclined to try it - what's "going on" already has and it was probably related to the charger? L

Select as Best AnswerUndo Best Answer

user
skunkbait (author)lemonie2009-04-14

OK, Tomorrow ( if I get up at a reasonable hour, It's my ""Weekend ") , I'll find out one way or the other. I think I have another bulb or two. I'll put them in first and see if they blow (without the charger). If they blow without the charger, I'll assume it's thee reguletor.

Select as Best AnswerUndo Best Answer

user
lemonie (author)skunkbait2009-04-14

I've blown 12V halogen spots with an unregulated 50cc scooter, but only at full revs (~20V). I guess you'll be able to see whether the regulator appears to be defective by slowly increasing the throttle?

L

Select as Best AnswerUndo Best Answer

user
skunkbait (author)lemonie2009-04-15

That's a thought. I have some cheap bulbs I could try.

Select as Best AnswerUndo Best Answer

user
Rishnai (author)2009-04-17

Wow. Sorry to hear all isn't well in the land of the bikes. I'd be inclined to blame it on the charger unless you've done the same exact procedure before without causing damage. Otherwise, I'd look at the regulator a little funny until I put in a known-good unit...even if it didn't blow the lights when you tested it without the charger.
Plus I'm a little jealous that you're not snowed in like this snow-country chump.

Select as Best AnswerUndo Best Answer

user
skunkbait (author)Rishnai2009-04-17

Hey, this is Arkansas. If you don't like the cold/heat/rain/drought, stick around. A tornado will be along shortly.

Select as Best AnswerUndo Best Answer

user
NachoMahma (author)2009-04-14

> I had a battery charger attached (charging 12v @ 6 amps). . That sounds a lot like a bad battery. . > fried the headlight, the taillight ... Defective regulator? . If you fried two incandescent lamps, I suspect high voltage (bad regulator). Could have just been coincidence - I've seen weirder things happen. . > Poor regulator ground? . Cleaning all the connections (including grounds) would probably be a good idea. I use a little bit of bulb or silicone grease when I put stuff back together to hold corrosion at bay. . > I want to ride this weekend ... . If you plan on riding south, stop by and say hi. PM me for address/telephone.

Select as Best AnswerUndo Best Answer

user
skunkbait (author)NachoMahma2009-04-14

Probably won't get any further south than Little Rock, until late June. I'll definitely give you a holler before I head that way.

Select as Best AnswerUndo Best Answer

user
frollard (author)2009-04-13

its possible the way the charger was attached boosted your battery voltage (if it was in series) from 12 volts to 24 volts...if that happened, by a stretch of the imagination, your lights would blow pretty quick...

Select as Best AnswerUndo Best Answer

user
skunkbait (author)frollard2009-04-14

I thought of that. It's remotely possible, but I don't know how. I had it hooked up "regular".

Select as Best AnswerUndo Best Answer

user
frollard (author)skunkbait2009-04-14

yeah, + to +, - to -...couldn't yield that result...its...weird.

Select as Best AnswerUndo Best Answer

user
roboteen (author)2009-04-13

get it to a repair shop it might be you left the charger on to long was it on all winter

Select as Best AnswerUndo Best Answer

user
skunkbait (author)roboteen2009-04-14

No, the charger was only on for about 10 minutes. I'll probably just let my oldest son work on it. He's only 15, but he's brilliant when it comes to bikes.

Select as Best AnswerUndo Best Answer